Apache Solr: Core-creation with "trusted" configset can use arbitrary untrusted files
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-250.
Summary
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Solr | up to 9.7 | — | No fix listed | CNA |
| — | org.apache.solr:solr-core (Maven) | before 9.8.0 | 9.8.0 | Patch available | GHSA-68r2-fwcg-qpm8 |
- Apache Solr VendorApache Affected up to 9.7 Fixed in — No fix listed CNA
- org.apache.solr:solr-core (Maven) Vendor— Affected before 9.8.0 Fixed in 9.8.0 Patch available GHSA-68r2-fwcg-qpm8
Remediation
- Fix · GHSA-68r2-fwcg-qpm8 org.apache.solr:solr-core (Maven) Fixed in 9.8.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Fuse 7 | Affected | No fix planned: Out of support scope |
| Red Hat Integration Camel K 1 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 8 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform Expansion Pack | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24814
- 2026-10-03 Alias added: GHSA-68r2-fwcg-qpm8
References
Advisory 4
More Apache Solr vulnerabilities
- TI-2024-30303 Apache Solr: Authentication bypass possible using a fake URL Path ending CVSS 3.1CRITICAL 9.8
- TI-2019-13101 Injection in Apache Solr KEVCVSS 3.1HIGH 7.5
- TI-2019-00170 Code injection in Apache Solr KEVCVSS 3.1HIGH 7.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2021-09240 SSRF vulnerability with the Replication handler CVSS 3.1CRITICAL 9.8
- TI-2017-09354 XML external entity injection in Apache Solr before 7.1 with Apache Lucene before 7.1 CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-24814 · CVE Program
- CVE-2025-24814 · NVD
- FIRST EPSS
- GHSA-68r2-fwcg-qpm8 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-24814 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences