Unauthorized AI bot activation via Wrangler plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to prevent Wrangler posts from triggering AI responses. This vulnerability allows users without access to the AI bot to activate it by attaching the activate_ai override property to a post via the Wrangler plugin, provided both the AI and Wrangler plugins are enabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 10.5.0 – 10.5.1; 10.4.0 – 10.4.3; 9.11.0 – 9.11.9 | 10.6.0, 10.5.2, 10.4.4, 9.11.10 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.5.0 to before 10.5.2 | 10.5.2 | Patch available | GHSA-j639-m367-75cf |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.4.0 to before 10.4.4 | 10.4.4 | Patch available | GHSA-j639-m367-75cf |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.11.0 to before 9.11.10 | 9.11.10 | Patch available | GHSA-j639-m367-75cf |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20250314142426-c049748b8863 | 8.0.0-20250314142426-c049748b8863 | Patch available | GHSA-j639-m367-75cf |
- Mattermost VendorMattermost Affected 10.5.0 – 10.5.1; 10.4.0 – 10.4.3; 9.11.0 – 9.11.9 Fixed in 10.6.0, 10.5.2, 10.4.4, 9.11.10 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.5.0 to before 10.5.2 Fixed in 10.5.2 Patch available GHSA-j639-m367-75cf
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.4.0 to before 10.4.4 Fixed in 10.4.4 Patch available GHSA-j639-m367-75cf
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.11.0 to before 9.11.10 Fixed in 9.11.10 Patch available GHSA-j639-m367-75cf
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20250314142426-c049748b8863 Fixed in 8.0.0-20250314142426-c049748b8863 Patch available GHSA-j639-m367-75cf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 9.11.0 to before 9.11.10; 10.4.0 to before 10.4.4; 10.5.0 to before 10.5.2 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 9.11.0 to before 9.11.10; 10.4.0 to before 10.4.4; 10.5.0 to before 10.5.2 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 10.6.0, 10.5.2, 10.4.4, 9.11.10
- Fix · GHSA-j639-m367-75cf github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.5.2 Advisory →
- Fix · GHSA-j639-m367-75cf github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.4.4 Advisory →
- Fix · GHSA-j639-m367-75cf github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.11.10 Advisory →
- Fix · GHSA-j639-m367-75cf github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20250314142426-c049748b8863 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24839
- 2026-10-03 Alias added: GHSA-j639-m367-75cf
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-24839 · CVE Program
- CVE-2025-24839 · NVD
- FIRST EPSS
- GHSA-j639-m367-75cf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences