Incorrect authorization in Apache Cassandra
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer. Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions. This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer. Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Cassandra | 4.0.0 – 4.0.15; 4.1.0 – 4.1.7; 5.0.0 – 5.0.2 | — | No fix listed | CNA |
| — | org.apache.cassandra:cassandra-all (Maven) | 4.0-alpha1 to before 4.0.16 | 4.0.16 | Patch available | GHSA-3cjf-fwcq-xh22 |
| — | org.apache.cassandra:cassandra-all (Maven) | 4.1-alpha1 to before 4.1.8 | 4.1.8 | Patch available | GHSA-3cjf-fwcq-xh22 |
| — | org.apache.cassandra:cassandra-all (Maven) | 5.0-alpha1 to before 5.0.3 | 5.0.3 | Patch available | GHSA-3cjf-fwcq-xh22 |
- Apache Cassandra VendorApache Affected 4.0.0 – 4.0.15; 4.1.0 – 4.1.7; 5.0.0 – 5.0.2 Fixed in — No fix listed CNA
- org.apache.cassandra:cassandra-all (Maven) Vendor— Affected 4.0-alpha1 to before 4.0.16 Fixed in 4.0.16 Patch available GHSA-3cjf-fwcq-xh22
- org.apache.cassandra:cassandra-all (Maven) Vendor— Affected 4.1-alpha1 to before 4.1.8 Fixed in 4.1.8 Patch available GHSA-3cjf-fwcq-xh22
- org.apache.cassandra:cassandra-all (Maven) Vendor— Affected 5.0-alpha1 to before 5.0.3 Fixed in 5.0.3 Patch available GHSA-3cjf-fwcq-xh22
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:* | 4.0.0 to before 4.0.16; 4.1.0 to before 4.1.8; 5.0.0 to before 5.0.3 | Vulnerable | Apache |
- cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.0.16; 4.1.0 to before 4.1.8; 5.0.0 to before 5.0.3 Vulnerable ·Apache
Remediation
- Fix · GHSA-3cjf-fwcq-xh22 org.apache.cassandra:cassandra-all (Maven) Fixed in 4.0.16 Advisory →
- Fix · GHSA-3cjf-fwcq-xh22 org.apache.cassandra:cassandra-all (Maven) Fixed in 4.1.8 Advisory →
- Fix · GHSA-3cjf-fwcq-xh22 org.apache.cassandra:cassandra-all (Maven) Fixed in 5.0.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 10 products
- A-MQ Clients 2
- Red Hat Data Grid 8
- Red Hat Fuse 7
- Red Hat Integration Camel K 1
- Red Hat JBoss Data Grid 7
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Enterprise Application Platform 8
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- Red Hat build of Quarkus
- streams for Apache Kafka
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24860
- 2026-10-03 Alias added: GHSA-3cjf-fwcq-xh22
References
Advisory 4
More Apache Cassandra vulnerabilities
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2021-20121 Remote code execution for scripted UDFs CVSS 3.1CRITICAL 9.1
- TI-2019-02233 Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent… CVSS 3.1MEDIUM 5.9
- TI-2018-05793 Missing authentication in Apache Cassandra CVSS 3.0CRITICAL 9.8
- TI-2016-04292 handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before… CVSS 3.1HIGH 7.5
- TI-2025-16827 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions CVSS 3.1HIGH 8.8
Sources
- CVE-2025-24860 · CVE Program
- CVE-2025-24860 · NVD
- FIRST EPSS
- GHSA-3cjf-fwcq-xh22 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-24860 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences