Bypassing MFA Enforcement on Plugin Endpoints
Priority MEDIUM 40CWE-306Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-306.
Summary
Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8, 10.5.x <= 10.5.0 fail to enforce MFA on plugin endpoints, which allows authenticated attackers to bypass MFA protections via API requests to plugin-specific routes.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00344 28th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 10.6.0, 10.4.3, 10.3.4 +2github.com/mattermost/mattermost/server/v8 (Go): 10.4.3, 10.3.4, 9.11.9 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 10.4.0 – 10.4.2; 10.3.0 – 10.3.3; 9.11.0 – 9.11.8; 10.5.0 | 10.6.0, 10.4.3, 10.3.4, 9.11.9, 10.5.1 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.4.0 to before 10.4.3 | 10.4.3 | Patch available | GHSA-72qv-j8vr-xvfv |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.3.0 to before 10.3.4 | 10.3.4 | Patch available | GHSA-72qv-j8vr-xvfv |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.11.0 to before 9.11.9 | 9.11.9 | Patch available | GHSA-72qv-j8vr-xvfv |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.5.0 to before 10.5.1 | 10.5.1 | Patch available | GHSA-72qv-j8vr-xvfv |
- Mattermost VendorMattermost Affected 10.4.0 – 10.4.2; 10.3.0 – 10.3.3; 9.11.0 – 9.11.8; 10.5.0 Fixed in 10.6.0, 10.4.3, 10.3.4, 9.11.9, 10.5.1 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.4.0 to before 10.4.3 Fixed in 10.4.3 Patch available GHSA-72qv-j8vr-xvfv
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.3.0 to before 10.3.4 Fixed in 10.3.4 Patch available GHSA-72qv-j8vr-xvfv
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.11.0 to before 9.11.9 Fixed in 9.11.9 Patch available GHSA-72qv-j8vr-xvfv
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.5.0 to before 10.5.1 Fixed in 10.5.1 Patch available GHSA-72qv-j8vr-xvfv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 9.11.0 to before 9.11.9; 10.3.0 to before 10.3.4; 10.4.0 to before 10.4.3; 10.5.0 to before 10.5.1 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 9.11.0 to before 9.11.9; 10.3.0 to before 10.3.4; 10.4.0 to before 10.4.3; 10.5.0 to before 10.5.1 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 10.6.0, 10.4.3, 10.3.4, 9.11.9, 10.5.1
- Fix · GHSA-72qv-j8vr-xvfv github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.4.3 Advisory →
- Fix · GHSA-72qv-j8vr-xvfv github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.3.4 Advisory →
- Fix · GHSA-72qv-j8vr-xvfv github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.11.9 Advisory →
- Fix · GHSA-72qv-j8vr-xvfv github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.5.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-25068
- 2026-10-03 Alias added: GHSA-72qv-j8vr-xvfv
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-25068 · CVE Program
- CVE-2025-25068 · NVD
- FIRST EPSS
- GHSA-72qv-j8vr-xvfv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences