Read the docs
TI-2025-19415 Aliases CVE-2025-26467GHSA-5c4f-pxmx-xcm4

Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to…

Priority MEDIUM 41CWE-267Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 5 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.

Summary

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected. Users in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00515 44th percentileScored 2026-11-07
Fix Partial org.apache.cassandra:cassandra-all (Maven): 4.0.17Red Hat: 5 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Cassandra4.0.16—No fix listedCNA
—org.apache.cassandra:cassandra-all (Maven)4.0.16 to before 4.0.174.0.17Patch availableGHSA-5c4f-pxmx-xcm4
  • Apache Cassandra VendorApache Affected 4.0.16 Fixed in — No fix listed CNA
  • org.apache.cassandra:cassandra-all (Maven) Vendor— Affected 4.0.16 to before 4.0.17 Fixed in 4.0.17 Patch available GHSA-5c4f-pxmx-xcm4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:*3.0.0 to before 3.0.31; 3.11.0 to before 3.11.18; 4.0.0 to before 4.0.17; 4.1.0 to before 4.1.8; 5.0.0 to before 5.0.3VulnerableApache
  • cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.0.31; 3.11.0 to before 3.11.18; 4.0.0 to before 4.0.17; 4.1.0 to before 4.1.8; 5.0.0 to before 5.0.3 Vulnerable ·Apache

Remediation

  • Fix · GHSA-5c4f-pxmx-xcm4 org.apache.cassandra:cassandra-all (Maven) Fixed in 4.0.17 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Data Grid 8AffectedNo fix yet: Fix deferred
Red Hat Fuse 7AffectedNo fix planned: Out of support scope
Red Hat JBoss Enterprise Application Platform 7AffectedNo fix yet: Fix deferred
Red Hat JBoss Enterprise Application Platform 8AffectedNo fix yet: Fix deferred
Red Hat JBoss Enterprise Application Platform Expansion PackAffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-26467
  2. 2026-10-03 Alias added: GHSA-5c4f-pxmx-xcm4

References

  • TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-20121 Remote code execution for scripted UDFs CVSS 3.1CRITICAL 9.1
  • TI-2019-02233 Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent… CVSS 3.1MEDIUM 5.9
  • TI-2018-05793 Missing authentication in Apache Cassandra CVSS 3.0CRITICAL 9.8
  • TI-2016-04292 handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before… CVSS 3.1HIGH 7.5
  • TI-2025-16827 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions CVSS 3.1HIGH 8.8
See all 15 →

Sources