Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vega | vega | before 5.31.0 | 5.31.0 | Patch available | CNA |
| — | vega (npm) | before 5.31.0 | 5.31.0 | Patch available | GHSA-rcw3-wmx7-cphr |
| — | vega-functions (npm) | before 5.16.0 | 5.16.0 | Patch available | GHSA-rcw3-wmx7-cphr |
- vega Vendorvega Affected before 5.31.0 Fixed in 5.31.0 Patch available CNA
- vega (npm) Vendor— Affected before 5.31.0 Fixed in 5.31.0 Patch available GHSA-rcw3-wmx7-cphr
- vega-functions (npm) Vendor— Affected before 5.16.0 Fixed in 5.16.0 Patch available GHSA-rcw3-wmx7-cphr
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vega-functions_project:vega-functions:*:*:*:*:*:node.js:*:* | before 5.16.0 | Vulnerable | Vega-functions Project |
| cpe:2.3:a:vega_project:vega:*:*:*:*:*:node.js:*:* | before 5.31.0 | Vulnerable | Vega Project |
- cpe:2.3:a:vega-functions_project:vega-functions:*:*:*:*:*:node.js:*:* Versions before 5.16.0 Vulnerable ·Vega-functions Project
- cpe:2.3:a:vega_project:vega:*:*:*:*:*:node.js:*:* Versions before 5.31.0 Vulnerable ·Vega Project
Remediation
- Fix · CNA vega (vega) Fixed in 5.31.0
- Fix · GHSA-rcw3-wmx7-cphr vega (npm) Fixed in 5.31.0 Advisory →
- Fix · GHSA-rcw3-wmx7-cphr vega-functions (npm) Fixed in 5.16.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-26619
- 2026-10-03 Alias added: GHSA-rcw3-wmx7-cphr
References
Exploit 2
More vega vulnerabilities
- TI-2025-40262 Cross-site scripting in vega CVSS 3.1CRITICAL 9.3
- TI-2025-18958 Vega allows Cross-site Scripting via the vlSelectionTuples function CVSS 4.0MEDIUM 6.9
- TI-2025-37279 Cross-site scripting in vega CVSS 3.1HIGH 8.1
- TI-2020-16117 Cross-site scripting in vega CVSS 3.1HIGH 8.7
- TI-2026-02866 VEGA: Privilege escalation through unsecured configuration interface in VEGAPULS devices CVSS 3.1HIGH 7.5
- TI-2025-41032 `vega-functions` vulnerable to Cross-site Scripting via `setdata` function CVSS 3.1HIGH 7.2
Sources
- CVE-2025-26619 · CVE Program
- CVE-2025-26619 · NVD
- FIRST EPSS
- GHSA-rcw3-wmx7-cphr · GitHub Advisory Database · CC BY 4.0
- CVE-2025-26619 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences