Cross-site scripting in vega
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Prior to versions 6.1.2 and 5.6.3, applications meeting two conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. First, they use `vega` in an application that attaches both `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window`, or has any other satisfactory function gadgets in the global scope. Second, they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). This vulnerability allows for DOM XSS, potentially stored, potentially reflected, depending on how the library is being used. The vulnerability requires user interaction with the page to trigger. An attacker can exploit this issue by tricking a user into opening a malicious Vega specification. Successful exploitation allows the attacker to execute arbitrary JavaScript in the context of the application’s domain. This can lead to theft of sensitive information such as authentication tokens, manipulation of data displayed to the user, or execution of unauthorized actions on behalf of the victim. This exploit compromises confidentiality and integrity of impacted applications.Patched versions are available in `[email protected]` (requires ESM) for Vega v6 and `[email protected]` (no ESM needed) for Vega v5. As a workaround, do not attach `vega` or `vega.View` instances to global variables or the window as the editor used to do. This is a development-only debugging practice that should not be used in any situation where Vega/Vega-lite definitions can come from untrusted parties.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vega | vega | before 5.6.3; 6.0.0 to before 6.1.2 | 5.6.3, 6.1.2 | Patch available | CNA |
| — | vega-selections (npm) | before 5.6.3 | 5.6.3 | Patch available | GHSA-829q-m3qg-ph8r |
| — | vega-selections (npm) | 6.0.0 to before 6.1.2 | 6.1.2 | Patch available | GHSA-829q-m3qg-ph8r |
- vega Vendorvega Affected before 5.6.3; 6.0.0 to before 6.1.2 Fixed in 5.6.3, 6.1.2 Patch available CNA
- vega-selections (npm) Vendor— Affected before 5.6.3 Fixed in 5.6.3 Patch available GHSA-829q-m3qg-ph8r
- vega-selections (npm) Vendor— Affected 6.0.0 to before 6.1.2 Fixed in 6.1.2 Patch available GHSA-829q-m3qg-ph8r
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vega_project:vega:*:*:*:*:*:node.js:*:* | before 5.6.3; 6.0.0 to before 6.1.2 | Vulnerable | Vega Project |
- cpe:2.3:a:vega_project:vega:*:*:*:*:*:node.js:*:* Versions before 5.6.3; 6.0.0 to before 6.1.2 Vulnerable ·Vega Project
Remediation
- Fix · CNA vega (vega) Fixed in 5.6.3, 6.1.2
- Fix · GHSA-829q-m3qg-ph8r vega-selections (npm) Fixed in 5.6.3 Advisory →
- Fix · GHSA-829q-m3qg-ph8r vega-selections (npm) Fixed in 6.1.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-65110
- 2026-10-03 Alias added: GHSA-829q-m3qg-ph8r
References
More vega vulnerabilities
- TI-2025-18958 Vega allows Cross-site Scripting via the vlSelectionTuples function CVSS 4.0MEDIUM 6.9
- TI-2025-37279 Cross-site scripting in vega CVSS 3.1HIGH 8.1
- TI-2025-19556 Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter` CVSS 4.0MEDIUM 5.3
- TI-2020-16117 Cross-site scripting in vega CVSS 3.1HIGH 8.7
- TI-2026-02866 VEGA: Privilege escalation through unsecured configuration interface in VEGAPULS devices CVSS 3.1HIGH 7.5
- TI-2025-41032 `vega-functions` vulnerable to Cross-site Scripting via `setdata` function CVSS 3.1HIGH 7.2
Sources
- CVE-2025-65110 · CVE Program
- CVE-2025-65110 · NVD
- FIRST EPSS
- GHSA-829q-m3qg-ph8r · GitHub Advisory Database · CC BY 4.0
- CVE-2025-65110 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences