Read the docs
TI-2025-19736 Aliases CVE-2025-26865GHSA-p9r8-xjx7-v86q

Apache OFBiz: Server-Side Template Injection affecting the ecommerce plugin leading to possible RCE

Priority LOW 18CWE-1336Published · Updated

Key facts

Attack vector
Physical
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-1336.

Summary

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Apache OFBiz. This issue affects Apache OFBiz: from 18.12.17 before 18.12.18.   It's a regression between 18.12.17 and 18.12.18. In case you use something like that, which is not recommended! For security, only official releases should be used. In other words, if you use 18.12.17 you are still safe. The version 18.12.17 is not a affected. But something between 18.12.17 and 18.12.18 is. In that case, users are recommended to upgrade to version 18.12.18, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0066 51st percentileScored 2026-11-07
Fix Fixed Apache OFBiz (Apache Software Foundation): 18.12.18

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache OFBiz18.12.17 to before 18.12.1818.12.18Patch availableCNA
  • Apache OFBiz VendorApache Affected 18.12.17 to before 18.12.18 Fixed in 18.12.18 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:ofbiz:18.12.17:*:*:*:*:*:*:*18.12.17VulnerableApache
  • cpe:2.3:a:apache:ofbiz:18.12.17:*:*:*:*:*:*:* Versions 18.12.17 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache OFBiz (Apache Software Foundation) Fixed in 18.12.18

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-26865
  2. 2026-10-03 Alias added: GHSA-p9r8-xjx7-v86q
  3. 2026-10-04 EPSS moved to the 50th–90th percentile

References

  • TI-2024-30292 Apache OFBiz: Confused controller-view authorization logic (forced browsing) KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-26062 Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-21190 Apache OFBiz: Path traversal leading to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-30542 Apache OFBiz: Prevent use of URLs in files when loading them from Java or Groovy, leading to a RCE CVSS 3.1CRITICAL 9.8
  • TI-2021-08129 RCE vulnerability in latest Apache OFBiz due to Java serialisation using RMI CVSS 3.1CRITICAL 9.8
  • TI-2023-28119 Apache OFBiz: Pre-authentication Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.8
See all 75 →

Sources