Read the docs
TI-2025-20430 Aliases CVE-2025-27624GHSA-7g95-jmg9-h524

Cross-site request forgery in Jenkins

Priority LOW 25CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A cross-site request forgery (CSRF) vulnerability in Jenkins 2.499 and earlier, LTS 2.492.1 and earlier allows attackers to have users toggle their collapsed/expanded status of sidepanel widgets (e.g., Build Queue and Build Executor Status widgets).

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00441 38th percentileScored 2026-11-07
Fix Fixed Jenkins (Jenkins Project): 2.492.2, 2.500org.jenkins-ci.main:jenkins-core (Maven): 2.500, 2.492.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins—2.492.2, 2.500Patch availableCNA
—org.jenkins-ci.main:jenkins-core (Maven)2.493 to before 2.5002.500Patch availableGHSA-7g95-jmg9-h524
—org.jenkins-ci.main:jenkins-core (Maven)before 2.492.22.492.2Patch availableGHSA-7g95-jmg9-h524
  • Jenkins VendorJenkins Affected — Fixed in 2.492.2, 2.500 Patch available CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.493 to before 2.500 Fixed in 2.500 Patch available GHSA-7g95-jmg9-h524
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.492.2 Fixed in 2.492.2 Patch available GHSA-7g95-jmg9-h524

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*before 2.492.2VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*before 2.500VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 2.492.2 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions before 2.500 Vulnerable ·Jenkins

Remediation

  • Fix · CNA Jenkins (Jenkins Project) Fixed in 2.492.2, 2.500
  • Fix · GHSA-7g95-jmg9-h524 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.500 Advisory →
  • Fix · GHSA-7g95-jmg9-h524 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.492.2 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Jenkins — Jenkins Security Advisory 2025-03-05

    4 records Highest priority Priority LOW 4 LOW

    Other records, highest priority first

    • TI-2025-20431 Open redirect in JenkinsPriority LOW 21
    • TI-2025-20428 Cleartext storage of sensitive information in JenkinsPriority LOW 21
    • TI-2025-20429 Cleartext storage of sensitive information in JenkinsPriority LOW 20

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 2 products
  • OpenShift Developer Tools and Services
  • Red Hat Developer Hub 1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-27624
  2. 2026-10-03 Alias added: GHSA-7g95-jmg9-h524
  3. 2026-10-27 Affected versions changed · Red Hat

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources