Privilege Escalation Vulnerability in AA-Team WordPress plugins
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-266.
Summary
Incorrect Privilege Assignment vulnerability in AA-Team Premium Age Verification / Restriction for WordPress, AA-Team Responsive Coming Soon Landing Page / Holding Page for WordPress allows Privilege Escalation.This issue affects Premium Age Verification / Restriction for WordPress: from n/a through 3.0.2; Responsive Coming Soon Landing Page / Holding Page for WordPress: from n/a through 3.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-29004
- 2026-10-03 Alias added: GHSA-49f7-mmjq-mr5h
References
Other 2
- https://patchstack.com/database/wordpress/plugin/age-restriction/vulnerability/wordpress-premium-age-verification-restriction-for-wordpress-plugin-3-0-2-privilege-escalation-vulnerability?_s_id=cve
- https://patchstack.com/database/wordpress/plugin/wordpress-flat-countdown/vulnerability/wordpress-responsive-coming-soon-landing-page-holding-page-for-wordpress-3-0-privilege-escalation-vulnerability?_s_id=cve
More AA-Team vulnerabilities
- TI-2025-06742 Hard-coded credentials in AA-Team Premium Age Verification / Restriction for WordPress CVSS 3.1CRITICAL 9.8
- TI-2024-22132 WordPress WZone plugin <= 14.0.10 - Unauthenticated Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-22131 WordPress WZone plugin <= 14.0.10 - Unauthenticated SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
- TI-2025-21908 WordPress Amazon Native Shopping Recommendations Plugin <= 1.3 - SQL Injection Vulnerability CVSS 3.1CRITICAL 9.3
- TI-2024-22133 WordPress WZone plugin <= 14.0.10 - Arbitrary SQL Update Execution vulnerability CVSS 3.1CRITICAL 9.6
- TI-2024-22136 WordPress WZone plugin <= 14.0.10 - Privilege Escalation vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2025-29004 · CVE Program
- CVE-2025-29004 · NVD
- FIRST EPSS
- GHSA-49f7-mmjq-mr5h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences