Envoy crashes when HTTP ext_proc processes local replies
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Envoy is a cloud-native high-performance edge/middle/service proxy. Prior to 1.33.1, 1.32.4, 1.31.6, and 1.30.10, Envoy's ext_proc HTTP filter is at risk of crashing if a local reply is sent to the external server due to the filter's life time issue. A known situation is the failure of a websocket handshake will trigger a local reply leading to the crash of Envoy. This vulnerability is fixed in 1.33.1, 1.32.4, 1.31.6, and 1.30.10.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| envoyproxy | envoy | 1.33.0 to before 1.33.1; 1.32.0 to before 1.32.4; 1.31.0 to before 1.31.6; before 1.30.10 | 1.33.1, 1.32.4, 1.31.6, 1.30.10 | Patch available | CNA |
| — | github.com/envoyproxy/envoy (Go) | before 1.30.10 | 1.30.10 | Patch available | GHSA-cf3q-gqg7-3fm9 |
| — | github.com/envoyproxy/envoy (Go) | 1.31.0 to before 1.31.6 | 1.31.6 | Patch available | GHSA-cf3q-gqg7-3fm9 |
| — | github.com/envoyproxy/envoy (Go) | 1.32.0 to before 1.32.4 | 1.32.4 | Patch available | GHSA-cf3q-gqg7-3fm9 |
| — | github.com/envoyproxy/envoy (Go) | 1.33.0 to before 1.33.1 | 1.33.1 | Patch available | GHSA-cf3q-gqg7-3fm9 |
- envoy Vendorenvoyproxy Affected 1.33.0 to before 1.33.1; 1.32.0 to before 1.32.4; 1.31.0 to before 1.31.6; before 1.30.10 Fixed in 1.33.1, 1.32.4, 1.31.6, 1.30.10 Patch available CNA
- github.com/envoyproxy/envoy (Go) Vendor— Affected before 1.30.10 Fixed in 1.30.10 Patch available GHSA-cf3q-gqg7-3fm9
- github.com/envoyproxy/envoy (Go) Vendor— Affected 1.31.0 to before 1.31.6 Fixed in 1.31.6 Patch available GHSA-cf3q-gqg7-3fm9
- github.com/envoyproxy/envoy (Go) Vendor— Affected 1.32.0 to before 1.32.4 Fixed in 1.32.4 Patch available GHSA-cf3q-gqg7-3fm9
- github.com/envoyproxy/envoy (Go) Vendor— Affected 1.33.0 to before 1.33.1 Fixed in 1.33.1 Patch available GHSA-cf3q-gqg7-3fm9
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* | before 1.30.10; 1.31.0 to before 1.31.6; 1.32.0 to before 1.32.4 | Vulnerable | envoyproxy |
| cpe:2.3:a:envoyproxy:envoy:1.33.0:*:*:*:*:*:*:* | 1.33.0 | Vulnerable | envoyproxy |
- cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* Versions before 1.30.10; 1.31.0 to before 1.31.6; 1.32.0 to before 1.32.4 Vulnerable ·envoyproxy
- cpe:2.3:a:envoyproxy:envoy:1.33.0:*:*:*:*:*:*:* Versions 1.33.0 Vulnerable ·envoyproxy
Remediation
- Fix · CNA envoy (envoyproxy) Fixed in 1.33.1, 1.32.4, 1.31.6, 1.30.10
- Fix · GHSA-cf3q-gqg7-3fm9 github.com/envoyproxy/envoy (Go) Fixed in 1.30.10 Advisory →
- Fix · GHSA-cf3q-gqg7-3fm9 github.com/envoyproxy/envoy (Go) Fixed in 1.31.6 Advisory →
- Fix · GHSA-cf3q-gqg7-3fm9 github.com/envoyproxy/envoy (Go) Fixed in 1.32.4 Advisory →
- Fix · GHSA-cf3q-gqg7-3fm9 github.com/envoyproxy/envoy (Go) Fixed in 1.33.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30157
- 2026-10-03 Alias added: GHSA-cf3q-gqg7-3fm9
References
More envoyproxy Envoy vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-20001 HTTP/2: CPU exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2024-18524 HTTP/2: memory exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2023-12215 Envoy client may fake the header `x-envoy-original-path` CVSS 3.1CRITICAL 9.1
- TI-2023-18002 Envoy vulnerable to OAuth2 credentials exploit with permanent validity CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-30157 · CVE Program
- CVE-2025-30157 · NVD
- FIRST EPSS
- GHSA-cf3q-gqg7-3fm9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences