Read the docs
TI-2025-21507 Aliases CVE-2025-30168GHSA-837q-jhwx-cmpv

Parse Server has an OAuth login vulnerability

Priority LOW 31CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
High · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 7.5.2 and 8.0.2, the 3rd party authentication handling of Parse Server allows the authentication credentials of some specific authentication providers to be used across multiple Parse Server apps. For example, if a user signed up using the same authentication provider in two unrelated Parse Server apps, the credentials stored by one app can be used to authenticate the same user in the other app. Note that this only affects Parse Server apps that specifically use an affected 3rd party authentication provider for user authentication, for example by setting the Parse Server option auth to configure a Parse Server authentication adapter. The fix of this vulnerability requires to upgrade Parse Server to a version that includes the bug fix, as well as upgrade the client app to send a secure payload, which is different from the previous insecure payload. This vulnerability is fixed in 7.5.2 and 8.0.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00406 35th percentileScored 2026-11-07
Fix Fixed parse-server (parse-community): 7.5.2, 8.0.2parse-server (npm): 7.5.2, 8.0.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
parse-communityparse-serverbefore 7.5.2; 8.0.0 to before 8.0.27.5.2, 8.0.2Patch availableCNA
—parse-server (npm)before 7.5.27.5.2Patch availableGHSA-837q-jhwx-cmpv
—parse-server (npm)8.0.0 to before 8.0.28.0.2Patch availableGHSA-837q-jhwx-cmpv
  • parse-server Vendorparse-community Affected before 7.5.2; 8.0.0 to before 8.0.2 Fixed in 7.5.2, 8.0.2 Patch available CNA
  • parse-server (npm) Vendor— Affected before 7.5.2 Fixed in 7.5.2 Patch available GHSA-837q-jhwx-cmpv
  • parse-server (npm) Vendor— Affected 8.0.0 to before 8.0.2 Fixed in 8.0.2 Patch available GHSA-837q-jhwx-cmpv

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:*——parse-community
  • cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:* Versions — — ·parse-community

Remediation

  • Fix · CNA parse-server (parse-community) Fixed in 7.5.2, 8.0.2
  • Fix · GHSA-837q-jhwx-cmpv parse-server (npm) Fixed in 7.5.2 Advisory →
  • Fix · GHSA-837q-jhwx-cmpv parse-server (npm) Fixed in 8.0.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-30168
  2. 2026-10-03 Alias added: GHSA-837q-jhwx-cmpv

References

  • TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
  • TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
  • TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
  • TI-2025-35510 parse is a package designed to parse JavaScript SDK. CVSS 3.1MEDIUM 6.5
  • TI-2024-26265 ZDI-CAN-23894: Parse Server literalizeRegexPart SQL Injection Authentication Bypass Vulnerability CVSS 3.1CRITICAL 9.8
See all 158 →

Sources