A crafted zone can lead to an illegal memory access in the PowerDNS Recursor
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-476.
Summary
An attacker can publish a zone containing specific Resource Record Sets. Processing and caching results for these sets can lead to an illegal memory accesses and crash of the Recursor, causing a denial of service. The remedy is: upgrade to the patched 5.2.1 version. We would like to thank Volodymyr Ilyin for bringing this issue to our attention.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30195
- 2026-10-03 Alias added: GHSA-v9gv-mwp4-wx7g
References
More PowerDNS vulnerabilities
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2021-14878 PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by… CVSS 3.1HIGH 7.5
- TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
- TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
Sources
- CVE-2025-30195 · CVE Program
- CVE-2025-30195 · NVD
- FIRST EPSS
- GHSA-v9gv-mwp4-wx7g · GitHub Advisory Database · CC BY 4.0
- CVE-2025-30195 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences