Reflected Cross Site Scripting (XSS) vulnerability in AA-Team WordPress plugins
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in AA-Team Woocommerce Sales Funnel Builder, AA-Team Amazon Affiliates Addon for WPBakery Page Builder (formerly Visual Composer) allows Reflected XSS.This issue affects Woocommerce Sales Funnel Builder: from n/a through 1.1; Amazon Affiliates Addon for WPBakery Page Builder (formerly Visual Composer): from n/a through 1.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30631
- 2026-10-03 Alias added: GHSA-mf24-v8vp-hp87
References
Other 2
- https://patchstack.com/database/wordpress/plugin/woosales/vulnerability/wordpress-woocommerce-sales-funnel-builder-plugin-1-1-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/wordpress/plugin/azon-addon-js-composer/vulnerability/wordpress-amazon-affiliates-addon-for-wpbakery-page-builder-formerly-visual-composer-1-2-cross-site-scripting-xss-vulnerability?_s_id=cve
More AA-Team vulnerabilities
- TI-2025-06742 Hard-coded credentials in AA-Team Premium Age Verification / Restriction for WordPress CVSS 3.1CRITICAL 9.8
- TI-2024-22132 WordPress WZone plugin <= 14.0.10 - Unauthenticated Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-22131 WordPress WZone plugin <= 14.0.10 - Unauthenticated SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
- TI-2025-21908 WordPress Amazon Native Shopping Recommendations Plugin <= 1.3 - SQL Injection Vulnerability CVSS 3.1CRITICAL 9.3
- TI-2024-22133 WordPress WZone plugin <= 14.0.10 - Arbitrary SQL Update Execution vulnerability CVSS 3.1CRITICAL 9.6
- TI-2024-22136 WordPress WZone plugin <= 14.0.10 - Privilege Escalation vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2025-30631 · CVE Program
- CVE-2025-30631 · NVD
- FIRST EPSS
- GHSA-mf24-v8vp-hp87 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences