Apache OFBiz: Stored XSS Vulnerability
Priority MEDIUM 64CWE-80Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-80.
Summary
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache OFBiz. This issue affects Apache OFBiz: before 18.12.19. Users are recommended to upgrade to version 18.12.19, which fixes the issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.67607 99th percentileScored 2026-11-07
Fix Fixed Apache OFBiz (Apache Software Foundation): 18.12.19
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Apache OFBiz (Apache Software Foundation) Fixed in 18.12.19
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30676
- 2026-10-03 Alias added: GHSA-vhg6-m6c8-39c2
References
More Apache Ofbiz vulnerabilities
- TI-2024-30292 Apache OFBiz: Confused controller-view authorization logic (forced browsing) KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26062 Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code KEVCVSS 3.1CRITICAL 9.8
- TI-2024-21190 Apache OFBiz: Path traversal leading to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2024-30542 Apache OFBiz: Prevent use of URLs in files when loading them from Java or Groovy, leading to a RCE CVSS 3.1CRITICAL 9.8
- TI-2021-08129 RCE vulnerability in latest Apache OFBiz due to Java serialisation using RMI CVSS 3.1CRITICAL 9.8
- TI-2023-28119 Apache OFBiz: Pre-authentication Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-30676 · CVE Program
- CVE-2025-30676 · NVD
- FIRST EPSS
- GHSA-vhg6-m6c8-39c2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences