Read the docs
TI-2025-22858 Aliases CVE-2025-31721GHSA-wr6w-jxg7-qpfh

Missing authorization in Jenkins

Priority LOW 20CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-862.

Summary

A missing permission check in Jenkins 2.503 and earlier, LTS 2.492.2 and earlier allows attackers with Computer/Create permission but without Computer/Configure permission to copy an agent, gaining access to encrypted secrets in its configuration.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00392 33rd percentileScored 2026-11-07
Fix Partial Jenkins (Jenkins Project): 2.492.3, 2.504org.jenkins-ci.main:jenkins-core (Maven): 2.504, 2.492.3Red Hat: 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins—2.492.3, 2.504Patch availableCNA
—org.jenkins-ci.main:jenkins-core (Maven)2.500 to before 2.5042.504Patch availableGHSA-wr6w-jxg7-qpfh
—org.jenkins-ci.main:jenkins-core (Maven)before 2.492.32.492.3Patch availableGHSA-wr6w-jxg7-qpfh
  • Jenkins VendorJenkins Affected — Fixed in 2.492.3, 2.504 Patch available CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.500 to before 2.504 Fixed in 2.504 Patch available GHSA-wr6w-jxg7-qpfh
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.492.3 Fixed in 2.492.3 Patch available GHSA-wr6w-jxg7-qpfh

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*before 2.492.3VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*before 2.504VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 2.492.3 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions before 2.504 Vulnerable ·Jenkins

Remediation

  • Fix · CNA Jenkins (Jenkins Project) Fixed in 2.492.3, 2.504
  • Fix · GHSA-wr6w-jxg7-qpfh org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.504 Advisory →
  • Fix · GHSA-wr6w-jxg7-qpfh org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.492.3 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Jenkins — Jenkins Security Advisory 2025-04-02

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
OpenShift Developer Tools and ServicesAffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-31721
  2. 2026-10-03 Alias added: GHSA-wr6w-jxg7-qpfh

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources