ProcessMaker < 3.5.4 Authenticated Plugin Upload RCE
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
An unrestricted file upload vulnerability exists in ProcessMaker versions prior to 3.5.4 due to improper handling of uploaded plugin archives. An attacker with administrative privileges can upload a malicious .tar plugin file containing arbitrary PHP code. Upon installation, the plugin’s install() method is invoked, resulting in execution of attacker-supplied PHP code on the server with the privileges of the web server user. This vulnerability can be chained with CVE-2022-38577 — a privilege escalation flaw in the user profile page — to achieve full remote code execution from a low-privileged account.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ProcessMaker | ProcessMaker | before 3.5.4 | 3.5.4 | Patch available | CNA |
- ProcessMaker VendorProcessMaker Affected before 3.5.4 Fixed in 3.5.4 Patch available CNA
Remediation
- Fix · CNA ProcessMaker (ProcessMaker Inc.) Fixed in 3.5.4
Timeline
- 2026-10-02 Threatist record created from CVE-2025-34097
- 2026-10-03 Alias added: GHSA-vqrr-v7vg-qrp6
References
Exploit 2
Advisory 2
More ProcessMaker vulnerabilities
- TI-2013-06178 ProcessMaker Open Source < 2.5.2 neoclassic Skin PHP Code Execution CVSS 4.0HIGH 8.7
- TI-2021-22591 ProcessMaker 3.5.4 Local File Inclusion via Path Traversal CVSS 4.0MEDIUM 6.9
- TI-2022-18153 ProcessMaker before v3.5.4 was discovered to contain insecure permissions in the user… CVSS 3.1HIGH 8.8
- TI-2016-07407 Deserialization of untrusted data in ProcessMaker Enterprise CVSS 3.1HIGH 8.8
- TI-2020-10605 SQL injection in ProcessMaker CVSS 3.1HIGH 8.8
- TI-2020-10604 SQL injection in ProcessMaker CVSS 3.1HIGH 8.8
Sources
- CVE-2025-34097 · CVE Program
- CVE-2025-34097 · NVD
- FIRST EPSS
- GHSA-vqrr-v7vg-qrp6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences