Stored Cross-Site Scripting (XSS) in ThingsBoard
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
ThingsBoard in versions prior to v4.2.1 allows an authenticated user to upload malicious SVG images via the "Image Gallery", leading to a Stored Cross-Site Scripting (XSS) vulnerability. The exploit can be triggered when any user accesses the public API endpoint of the malicious SVG images, or if the malicious images are embedded in an `iframe` element, during a widget creation, deployed to any page of the platform (e.g., dashboards), and accessed during normal operations. The vulnerability resides in the `ImageController`, which fails to restrict the execution of JavaScript code when an image is loaded by the user's browser. This vulnerability can lead to the execution of malicious code in the context of other users' sessions, potentially compromising their accounts and allowing unauthorized actions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | org.thingsboard:application (Maven) | before 4.2.1 | 4.2.1 | Patch available | GHSA-fpq4-r87v-g246 |
- org.thingsboard:application (Maven) Vendor— Affected before 4.2.1 Fixed in 4.2.1 Patch available GHSA-fpq4-r87v-g246
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:thingsboard:thingsboard:*:*:*:*:*:*:*:* | before 4.2.1 | Vulnerable | ThingsBoard |
- cpe:2.3:a:thingsboard:thingsboard:*:*:*:*:*:*:*:* Versions before 4.2.1 Vulnerable ·ThingsBoard
Remediation
- Fix · GHSA-fpq4-r87v-g246 org.thingsboard:application (Maven) Fixed in 4.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-34281
- 2026-10-03 Alias added: GHSA-fpq4-r87v-g246
References
Advisory 2
More Thingsboard vulnerabilities
- TI-2023-24282 ThingsBoard before 3.5 allows Server-Side Template Injection if users are allowed to… CVSS 3.1HIGH 8.8
- TI-2022-18942 Cross Site Scripting (XSS) vulnerability in Things Board 3.4.1 allows remote attackers to… CVSS 3.1CRITICAL 9.6
- TI-2022-23955 ThingsBoard 3.4.1 could allow a remote authenticated attacker to achieve Vertical… CVSS 3.1HIGH 8.8
- TI-2022-22507 An issue was discovered in ThingsBoard 3.4.1, allows low privileged attackers… CVSS 3.1HIGH 8.8
- TI-2020-16789 ThingsBoard before v3.2 is vulnerable to Host header injection in password-reset emails. CVSS 3.1HIGH 8.8
- TI-2025-24420 ThingsBoard < v4.2.1 SVG Image SSRF CVSS 4.0MEDIUM 6.9
Sources
- CVE-2025-34281 · CVE Program
- CVE-2025-34281 · NVD
- FIRST EPSS
- GHSA-fpq4-r87v-g246 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences