Read the docs
TI-2025-24521 Aliases CVE-2025-34469GHSA-83jg-m2pm-4jxj

Cowrie < 2.9.0 Unrestricted wget/curl Emulation Enables SSRF-Based DDoS Amplification

Priority HIGH 70CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.

Summary

Cowrie versions prior to 2.9.0 contain a server-side request forgery (SSRF) vulnerability in the emulated shell implementation of wget and curl. In the default emulated shell configuration, these command emulations perform real outbound HTTP requests to attacker-supplied destinations. Because no outbound request rate limiting was enforced, unauthenticated remote attackers could repeatedly invoke these commands to generate unbounded HTTP traffic toward arbitrary third-party targets, allowing the Cowrie honeypot to be abused as a denial-of-service amplification node and masking the attacker’s true source address behind the honeypot’s IP.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00675 52nd percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed Cowrie (Cowrie): 2.9.0cowrie (PyPI): 2.9.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
CowrieCowriebefore 2.9.02.9.0Patch availableCNA
—cowrie (PyPI)before 2.9.02.9.0Patch availableGHSA-83jg-m2pm-4jxj
  • Cowrie VendorCowrie Affected before 2.9.0 Fixed in 2.9.0 Patch available CNA
  • cowrie (PyPI) Vendor— Affected before 2.9.0 Fixed in 2.9.0 Patch available GHSA-83jg-m2pm-4jxj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:cowrie:cowrie:*:*:*:*:*:*:*:*before 2.9.0VulnerableCowrie
  • cpe:2.3:a:cowrie:cowrie:*:*:*:*:*:*:*:* Versions before 2.9.0 Vulnerable ·Cowrie

Remediation

  • Fix · CNA Cowrie (Cowrie) Fixed in 2.9.0
  • Fix · GHSA-83jg-m2pm-4jxj cowrie (PyPI) Fixed in 2.9.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-34469
  2. 2026-10-03 Alias added: GHSA-83jg-m2pm-4jxj

References

Sources