Arcserve UDP < 10.2 Reflected Cross-Site Scripting (XSS)
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A reflected cross-site scripting (XSS) vulnerability exists in the web interface of the Arcserve Unified Data Protection (UDP), where unsanitized user input is improperly reflected in HTTP responses. This flaw allows remote attackers with low privileges to craft malicious links that, when visited by another user, execute arbitrary JavaScript in the victim’s browser. Successful exploitation may lead to session hijacking, credential theft, or other client-side impacts. The vulnerability requires user interaction and occurs within a shared browser context. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Arcserve | Unified Data Protection (UDP) | 8.0 – 10.1; all versions | 10.2 | Patch available | CNA |
- Unified Data Protection (UDP) VendorArcserve Affected 8.0 – 10.1; all versions Fixed in 10.2 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:arcserve:udp:*:*:*:*:*:*:*:* | before 7.0; 8.0 to before 10.2 | Vulnerable | Arcserve |
| cpe:2.3:a:arcserve:udp:7.0:-:*:*:*:*:*:* | 7.0 | Vulnerable | Arcserve |
| cpe:2.3:a:arcserve:udp:7.0:update_1:*:*:*:*:*:* | 7.0 update_1 | Vulnerable | Arcserve |
| cpe:2.3:a:arcserve:udp:7.0:update_2:*:*:*:*:*:* | 7.0 update_2 | Vulnerable | Arcserve |
- cpe:2.3:a:arcserve:udp:*:*:*:*:*:*:*:* Versions before 7.0; 8.0 to before 10.2 Vulnerable ·Arcserve
- cpe:2.3:a:arcserve:udp:7.0:-:*:*:*:*:*:* Versions 7.0 Vulnerable ·Arcserve
- cpe:2.3:a:arcserve:udp:7.0:update_1:*:*:*:*:*:* Versions 7.0 update_1 Vulnerable ·Arcserve
- cpe:2.3:a:arcserve:udp:7.0:update_2:*:*:*:*:*:* Versions 7.0 update_2 Vulnerable ·Arcserve
Remediation
- Fix · CNA Unified Data Protection (UDP) (Arcserve) Fixed in 10.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Arcserve Unified Data Protection (UDP) — support.arcserve.com/s/article/Important-Security-Bulletin-…
4 records Highest priority Priority MEDIUM 2 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2025-24547 Arcserve UDP < 10.2 Pre-Authentication Heap OverflowPriority MEDIUM 42
- TI-2025-24546 Arcserve UDP < 10.2 Pre-Authentication Heap OverflowPriority MEDIUM 42
- TI-2025-24544 Arcserve UDP < 10.2 Authentication BypassPriority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2025-34521
- 2026-10-03 Alias added: GHSA-h6g8-8gr5-822r
References
More Arcserve Udp vulnerabilities
- TI-2015-03429 Directory traversal vulnerability in Arcserve UDP before 5.0 Update 4 allows remote… KEVCVSS 3.1CRITICAL 9.1
- TI-2024-00736 Authentication Bypass via wizardLogin in Arcserve Unified Data Protection CVSS 3.1CRITICAL 9.8
- TI-2023-11421 Arcserve UDP through 9.0.6034 allows authentication bypass. CVSS 3.1CRITICAL 9.8
- TI-2024-00737 Authentication Bypass via wizardLogin in Arcserve Unified Data Protection CVSS 3.1HIGH 8.8
- TI-2024-00738 Unauthenticated DoS in Arcserve Unified Data Protection CVSS 3.1HIGH 7.5
- TI-2023-22379 Arcserve UDP Unauthenticated RCE CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-34521 · CVE Program
- CVE-2025-34521 · NVD
- FIRST EPSS
- GHSA-h6g8-8gr5-822r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences