Arcserve UDP < 10.2 Pre-Authentication Heap Overflow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-122 and the CVSS impact.
Summary
A heap-based buffer overflow vulnerability exists in the input parsing logic of Arcserve Unified Data Protection (UDP). This flaw can be triggered without authentication by sending specially crafted input to the target system. Improper bounds checking allows an attacker to overwrite heap memory, potentially leading to application crashes or remote code execution. Exploitation occurs in the context of the affected process and does not require user interaction. The vulnerability poses a high risk due to its pre-authentication nature and potential for full compromise. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Arcserve | Unified Data Protection (UDP) | 8.0 – 10.1; all versions | 10.2 | Patch available | CNA |
- Unified Data Protection (UDP) VendorArcserve Affected 8.0 – 10.1; all versions Fixed in 10.2 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:arcserve:udp:*:*:*:*:*:*:*:* | before 7.0; 8.0 to before 10.2 | Vulnerable | Arcserve |
| cpe:2.3:a:arcserve:udp:7.0:-:*:*:*:*:*:* | 7.0 | Vulnerable | Arcserve |
| cpe:2.3:a:arcserve:udp:7.0:update_1:*:*:*:*:*:* | 7.0 update_1 | Vulnerable | Arcserve |
| cpe:2.3:a:arcserve:udp:7.0:update_2:*:*:*:*:*:* | 7.0 update_2 | Vulnerable | Arcserve |
- cpe:2.3:a:arcserve:udp:*:*:*:*:*:*:*:* Versions before 7.0; 8.0 to before 10.2 Vulnerable ·Arcserve
- cpe:2.3:a:arcserve:udp:7.0:-:*:*:*:*:*:* Versions 7.0 Vulnerable ·Arcserve
- cpe:2.3:a:arcserve:udp:7.0:update_1:*:*:*:*:*:* Versions 7.0 update_1 Vulnerable ·Arcserve
- cpe:2.3:a:arcserve:udp:7.0:update_2:*:*:*:*:*:* Versions 7.0 update_2 Vulnerable ·Arcserve
Remediation
- Fix · CNA Unified Data Protection (UDP) (Arcserve) Fixed in 10.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Arcserve Unified Data Protection (UDP) — support.arcserve.com/s/article/Important-Security-Bulletin-…
4 records Highest priority Priority MEDIUM 2 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2025-24547 Arcserve UDP < 10.2 Pre-Authentication Heap OverflowPriority MEDIUM 42
- TI-2025-24544 Arcserve UDP < 10.2 Authentication BypassPriority LOW 36
- TI-2025-24545 Arcserve UDP < 10.2 Reflected Cross-Site Scripting (XSS)Priority LOW 21
Timeline
- 2026-10-02 Threatist record created from CVE-2025-34522
- 2026-10-03 Alias added: GHSA-vvg7-q6v7-c4xg
References
More Arcserve Udp vulnerabilities
- TI-2015-03429 Directory traversal vulnerability in Arcserve UDP before 5.0 Update 4 allows remote… KEVCVSS 3.1CRITICAL 9.1
- TI-2024-00736 Authentication Bypass via wizardLogin in Arcserve Unified Data Protection CVSS 3.1CRITICAL 9.8
- TI-2023-11421 Arcserve UDP through 9.0.6034 allows authentication bypass. CVSS 3.1CRITICAL 9.8
- TI-2024-00737 Authentication Bypass via wizardLogin in Arcserve Unified Data Protection CVSS 3.1HIGH 8.8
- TI-2024-00738 Unauthenticated DoS in Arcserve Unified Data Protection CVSS 3.1HIGH 7.5
- TI-2023-22379 Arcserve UDP Unauthenticated RCE CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-34522 · CVE Program
- CVE-2025-34522 · NVD
- FIRST EPSS
- GHSA-vvg7-q6v7-c4xg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences