Elasticsearch Improper Authentication
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass, Spoofing
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287 and CWE-295.
Summary
Improper Authentication in Elasticsearch PKI realm can lead to user impersonation via specially crafted client certificates. A malicious actor would need to have such a crafted client certificate signed by a legitimate, trusted Certificate Authority.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elasticsearch | 7.0.0 – 7.17.29; 8.0.0 – 8.19.7; 9.0.0 – 9.1.7; 9.2.0 – 9.2.1 | — | No fix listed | CNA |
| — | org.elasticsearch.plugin:x-pack-security (Maven) | 7.0.0-alpha1 to before 8.19.8 | 8.19.8 | Patch available | GHSA-m9gh-789g-q5pv |
| — | org.elasticsearch.plugin:x-pack-security (Maven) | 9.0.0-beta1 to before 9.1.8 | 9.1.8 | Patch available | GHSA-m9gh-789g-q5pv |
| — | org.elasticsearch.plugin:x-pack-security (Maven) | 9.2.0 to before 9.2.2 | 9.2.2 | Patch available | GHSA-m9gh-789g-q5pv |
| — | org.elasticsearch.plugin:x-pack-core (Maven) | 7.0.0-alpha1 to before 8.19.8 | 8.19.8 | Patch available | GHSA-m9gh-789g-q5pv |
| — | org.elasticsearch.plugin:x-pack-core (Maven) | 9.0.0-beta1 to before 9.1.8 | 9.1.8 | Patch available | GHSA-m9gh-789g-q5pv |
| — | org.elasticsearch.plugin:x-pack-core (Maven) | 9.2.0 to before 9.2.2 | 9.2.2 | Patch available | GHSA-m9gh-789g-q5pv |
- Elasticsearch VendorElastic Affected 7.0.0 – 7.17.29; 8.0.0 – 8.19.7; 9.0.0 – 9.1.7; 9.2.0 – 9.2.1 Fixed in — No fix listed CNA
- org.elasticsearch.plugin:x-pack-security (Maven) Vendor— Affected 7.0.0-alpha1 to before 8.19.8 Fixed in 8.19.8 Patch available GHSA-m9gh-789g-q5pv
- org.elasticsearch.plugin:x-pack-security (Maven) Vendor— Affected 9.0.0-beta1 to before 9.1.8 Fixed in 9.1.8 Patch available GHSA-m9gh-789g-q5pv
- org.elasticsearch.plugin:x-pack-security (Maven) Vendor— Affected 9.2.0 to before 9.2.2 Fixed in 9.2.2 Patch available GHSA-m9gh-789g-q5pv
- org.elasticsearch.plugin:x-pack-core (Maven) Vendor— Affected 7.0.0-alpha1 to before 8.19.8 Fixed in 8.19.8 Patch available GHSA-m9gh-789g-q5pv
- org.elasticsearch.plugin:x-pack-core (Maven) Vendor— Affected 9.0.0-beta1 to before 9.1.8 Fixed in 9.1.8 Patch available GHSA-m9gh-789g-q5pv
- org.elasticsearch.plugin:x-pack-core (Maven) Vendor— Affected 9.2.0 to before 9.2.2 Fixed in 9.2.2 Patch available GHSA-m9gh-789g-q5pv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:* | 7.0.0 – 7.17.29; 8.0.0 to before 8.19.8; 9.0.0 to before 9.1.8; 9.2.0 to before 9.2.2 | Vulnerable | Elastic |
- cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:* Versions 7.0.0 – 7.17.29; 8.0.0 to before 8.19.8; 9.0.0 to before 9.1.8; 9.2.0 to before 9.2.2 Vulnerable ·Elastic
Remediation
- Fix · GHSA-m9gh-789g-q5pv org.elasticsearch.plugin:x-pack-security (Maven) Fixed in 8.19.8 Advisory →
- Fix · GHSA-m9gh-789g-q5pv org.elasticsearch.plugin:x-pack-security (Maven) Fixed in 9.1.8 Advisory →
- Fix · GHSA-m9gh-789g-q5pv org.elasticsearch.plugin:x-pack-security (Maven) Fixed in 9.2.2 Advisory →
- Fix · GHSA-m9gh-789g-q5pv org.elasticsearch.plugin:x-pack-core (Maven) Fixed in 8.19.8 Advisory →
- Fix · GHSA-m9gh-789g-q5pv org.elasticsearch.plugin:x-pack-core (Maven) Fixed in 9.1.8 Advisory →
- Fix · GHSA-m9gh-789g-q5pv org.elasticsearch.plugin:x-pack-core (Maven) Fixed in 9.2.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Logging Subsystem for Red Hat OpenShift | Affected | No fix yet |
| OpenShift Service Mesh 2 | Affected | No fix yet |
| Red Hat Quay 3 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-37731
- 2026-10-03 Alias added: GHSA-m9gh-789g-q5pv
References
Advisory 2
Other 4
- https://github.com/elastic/elasticsearch/commit/cd97b8566bf56e628070021300784cb9cee0286f
- https://github.com/elastic/elasticsearch/commit/d8a408da79f214395845d99d241e832077045983
- https://github.com/elastic/elasticsearch/commit/e519fe4c51a3c887675eb7daea2f914738847f23
- https://github.com/elastic/elasticsearch
More Elasticsearch vulnerabilities
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
- TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
- TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2025-37731 · CVE Program
- CVE-2025-37731 · NVD
- FIRST EPSS
- GHSA-m9gh-789g-q5pv · GitHub Advisory Database · CC BY 4.0
- CVE-2025-37731 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences