Improper authentication in Dell ObjectScale
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-287.
Summary
Dell ObjectScale, versions prior to ObjectScale 4.4.0.0, contains an Improper Authentication vulnerability. An unauthenticated attacker with remote access could potentially exploit this vulnerability, leading to Unauthorized access.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA ObjectScale (Dell) Fixed in 4.4.0.0 or later
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Dell ObjectScale — dell.com/support/kbdoc/en-in/000505935/dsa-2026-393-securit…
3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2026-49194 Deserialization of untrusted data in Dell ObjectScalePriority MEDIUM 50
- TI-2026-53258 Incorrect permission assignment in Dell ObjectScalePriority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2025-43936
- 2026-10-03 Alias added: GHSA-5rgh-vcq9-r69c
References
More Dell Objectscale vulnerabilities
- TI-2026-49194 Deserialization of untrusted data in Dell ObjectScale CVSS 3.1CRITICAL 10.0
- TI-2026-29362 Hard-coded credentials in Dell ECS CVSS 3.1CRITICAL 9.8
- TI-2026-27313 CSV injection in Dell ECS CVSS 3.1CRITICAL 9.8
- TI-2026-17882 Dell ECS, versions 3.8.1.0 through 3.8.1.7, and Dell ObjectScale versions prior to… CVSS 3.1HIGH 8.8
- TI-2025-19424 Improper input validation in Dell ECS CVSS 3.1HIGH 8.8
- TI-2026-42719 OS command injection in Dell ObjectScale CVSS 3.1HIGH 7.8
Sources
- CVE-2025-43936 · CVE Program
- CVE-2025-43936 · NVD
- FIRST EPSS
- GHSA-5rgh-vcq9-r69c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences