Incorrect permission assignment in Dell ObjectScale
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Dell ObjectScale, versions prior to 4.4.0.0, contains an Incorrect Permission Assignment for Critical Resource vulnerability in the OS. A high privileged attacker with remote access could potentially exploit this vulnerability, leading to Denial of service.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA ObjectScale (Dell) Fixed in 4.4.0.0 or later
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Dell ObjectScale — dell.com/support/kbdoc/en-in/000505935/dsa-2026-393-securit…
3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2026-49194 Deserialization of untrusted data in Dell ObjectScalePriority MEDIUM 50
- TI-2025-28502 Improper authentication in Dell ObjectScalePriority MEDIUM 42
Timeline
- 2026-10-02 Threatist record created from CVE-2026-76104
- 2026-10-03 Alias added: GHSA-c4qj-8235-frwj
References
More Dell Objectscale vulnerabilities
- TI-2026-49194 Deserialization of untrusted data in Dell ObjectScale CVSS 3.1CRITICAL 10.0
- TI-2026-29362 Hard-coded credentials in Dell ECS CVSS 3.1CRITICAL 9.8
- TI-2026-27313 CSV injection in Dell ECS CVSS 3.1CRITICAL 9.8
- TI-2025-28502 Improper authentication in Dell ObjectScale CVSS 3.1CRITICAL 9.1
- TI-2026-17882 Dell ECS, versions 3.8.1.0 through 3.8.1.7, and Dell ObjectScale versions prior to… CVSS 3.1HIGH 8.8
- TI-2025-19424 Improper input validation in Dell ECS CVSS 3.1HIGH 8.8
Sources
- CVE-2026-76104 · CVE Program
- CVE-2026-76104 · NVD
- FIRST EPSS
- GHSA-c4qj-8235-frwj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences