Apache APISIX: improper validation of issuer from introspection discovery url in plugin openid-connect
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
A vulnerability of plugin openid-connect in Apache APISIX. This vulnerability will only have an impact if all of the following conditions are met: 1. Use the openid-connect plugin with introspection mode 2. The auth service connected to openid-connect provides services to multiple issuers 3. Multiple issuers share the same private key and relies only on the issuer being different If affected by this vulnerability, it would allow an attacker with a valid account on one of the issuers to log into the other issuer. This issue affects Apache APISIX: until 3.12.0. Users are recommended to upgrade to version 3.12.0 or higher.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Apache APISIX (Apache Software Foundation) Fixed in 3.12.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-46647
- 2026-10-03 Alias added: GHSA-495r-5j65-5hp3
References
More Apache Apisix vulnerabilities
- TI-2022-08057 apisix/batch-requests plugin allows overwriting the X-REAL-IP header KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2020-10921 In Apache APISIX, the user enabled the Admin API and deleted the Admin API access IP… CVSS 3.1MEDIUM 6.5
- TI-2026-24457 Apache APISIX: forward auth plugin allows header injection CVSS 3.1CRITICAL 9.1
- TI-2022-09331 Apache APISIX: the body_schema check in request-validation plugin can be bypassed CVSS 3.1CRITICAL 9.8
- TI-2021-19447 Path traversal in request_uri variable CVSS 3.1HIGH 7.5
Sources
- CVE-2025-46647 · CVE Program
- CVE-2025-46647 · NVD
- FIRST EPSS
- GHSA-495r-5j65-5hp3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences