Envoy vulnerable to bypass of RBAC uri_template permission
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Envoy is a cloud-native edge/middle/service proxy. Prior to versions 1.34.1, 1.33.3, 1.32.6, and 1.31.8, Envoy's URI template matcher incorrectly excludes the `*` character from a set of valid characters in the URI path. As a result URI path containing the `*` character will not match a URI template expressions. This can result in bypass of RBAC rules when configured using the `uri_template` permissions. This vulnerability is fixed in Envoy versions v1.34.1, v1.33.3, v1.32.6, v1.31.8. As a workaround, configure additional RBAC permissions using `url_path` with `safe_regex` expression.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| envoyproxy | envoy | before 1.31.8; 1.32.0 to before 1.32.6; 1.33.0 to before 1.33.3; 1.34.0 to before 1.34.1 | 1.31.8, 1.32.6, 1.33.3, 1.34.1 | Patch available | CNA |
- envoy Vendorenvoyproxy Affected before 1.31.8; 1.32.0 to before 1.32.6; 1.33.0 to before 1.33.3; 1.34.0 to before 1.34.1 Fixed in 1.31.8, 1.32.6, 1.33.3, 1.34.1 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* | before 1.31.8; 1.32.0 to before 1.32.6; 1.33.0 to before 1.33.3 | Vulnerable | envoyproxy |
| cpe:2.3:a:envoyproxy:envoy:1.34.0:*:*:*:*:*:*:* | 1.34.0 | Vulnerable | envoyproxy |
- cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* Versions before 1.31.8; 1.32.0 to before 1.32.6; 1.33.0 to before 1.33.3 Vulnerable ·envoyproxy
- cpe:2.3:a:envoyproxy:envoy:1.34.0:*:*:*:*:*:*:* Versions 1.34.0 Vulnerable ·envoyproxy
Remediation
- Fix · CNA envoy (envoyproxy) Fixed in 1.31.8, 1.32.6, 1.33.3, 1.34.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-46821
References
More envoyproxy Envoy vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-20001 HTTP/2: CPU exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2024-18524 HTTP/2: memory exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2023-12215 Envoy client may fake the header `x-envoy-original-path` CVSS 3.1CRITICAL 9.1
- TI-2023-18002 Envoy vulnerable to OAuth2 credentials exploit with permanent validity CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences