undici Denial of Service attack via bad certificate data
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 13 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-401.
Summary
Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | undici | before 5.29.0; 6.0.0 to before 6.21.2; 7.0.0 to before 7.5.0 | 5.29.0, 6.21.2, 7.5.0 | Patch available | CNA |
| — | undici (npm) | before 5.29.0 | 5.29.0 | Patch available | GHSA-cxrh-j4jr-qwg3 |
| — | undici (npm) | 6.0.0 to before 6.21.2 | 6.21.2 | Patch available | GHSA-cxrh-j4jr-qwg3 |
| — | undici (npm) | 7.0.0 to before 7.5.0 | 7.5.0 | Patch available | GHSA-cxrh-j4jr-qwg3 |
- undici VendorNodeJS Affected before 5.29.0; 6.0.0 to before 6.21.2; 7.0.0 to before 7.5.0 Fixed in 5.29.0, 6.21.2, 7.5.0 Patch available CNA
- undici (npm) Vendor— Affected before 5.29.0 Fixed in 5.29.0 Patch available GHSA-cxrh-j4jr-qwg3
- undici (npm) Vendor— Affected 6.0.0 to before 6.21.2 Fixed in 6.21.2 Patch available GHSA-cxrh-j4jr-qwg3
- undici (npm) Vendor— Affected 7.0.0 to before 7.5.0 Fixed in 7.5.0 Patch available GHSA-cxrh-j4jr-qwg3
Remediation
- Fix · CNA undici (nodejs) Fixed in 5.29.0, 6.21.2, 7.5.0
- Fix · GHSA-cxrh-j4jr-qwg3 undici (npm) Fixed in 5.29.0 Advisory →
- Fix · GHSA-cxrh-j4jr-qwg3 undici (npm) Fixed in 6.21.2 Advisory →
- Fix · GHSA-cxrh-j4jr-qwg3 undici (npm) Fixed in 7.5.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Cryostat 4 | Affected | No fix yet: Fix deferred |
| OpenShift Lightspeed | Affected | No fix yet: Fix deferred |
| OpenShift Pipelines | Affected | No fix yet: Fix deferred |
| OpenShift Serverless | Affected | No fix yet: Fix deferred |
| Red Hat Developer Hub 1 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 8 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform Expansion Pack | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Dev Spaces | Affected | No fix yet: Fix deferred |
| Red Hat Openshift Data Foundation 4 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47279
- 2026-10-03 Alias added: GHSA-cxrh-j4jr-qwg3
- 2026-10-27 Affected versions changed · Red Hat
References
More NodeJS vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18584 Race condition in NodeJS Node CVSS 3.0HIGH 8.2
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2025-47279 · CVE Program
- CVE-2025-47279 · NVD
- FIRST EPSS
- GHSA-cxrh-j4jr-qwg3 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-47279 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences