Stored XSS in CE Phoenix Cart Testimonials Allows Account Takeover if Missing HttpOnly Flag
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
CE Phoenix is a free, open-source eCommerce platform. A stored cross-site scripting (XSS) vulnerability was discovered in CE Phoenix versions 1.0.9.9 through 1.1.0.2 where an attacker can inject malicious JavaScript into the testimonial description field. Once submitted, if the shop owner (admin) approves the testimonial, the script executes in the context of any user visiting the testimonial page. Because the session cookies are not marked with the `HttpOnly` flag, they can be exfiltrated by the attacker — potentially leading to account takeover. Version 1.1.0.3 fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| CE-PhoenixCart | PhoenixCart | 1.0.9.7 to before 1.1.0.3 | 1.1.0.3 | Patch available | CNA |
- PhoenixCart VendorCE-PhoenixCart Affected 1.0.9.7 to before 1.1.0.3 Fixed in 1.1.0.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phoenixcart:ce_phoenix_cart:*:*:*:*:*:*:*:* | before 1.1.0.3 | Vulnerable | PhoenixCart |
- cpe:2.3:a:phoenixcart:ce_phoenix_cart:*:*:*:*:*:*:*:* Versions before 1.1.0.3 Vulnerable ·PhoenixCart
Remediation
- Fix · CNA PhoenixCart (CE-PhoenixCart) Fixed in 1.1.0.3
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47289
References
More CE-PhoenixCart vulnerabilities
- TI-2025-29802 PhoenixCart Vulnerable to Account Deletion Without Password Confirmation CVSS 3.1MEDIUM 5.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences