Read the docs
TI-2025-30697 Aliases CVE-2025-48371GHSA-c72g-53hw-82q7

OpenFGA Authorization Bypass

Priority LOW 27CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-285.

Summary

OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00503 43rd percentileScored 2026-11-07
Fix Fixed openfga (openfga): 1.8.13github.com/openfga/openfga (Go): 1.8.13

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
openfgaopenfga1.8.0 to before 1.8.131.8.13Patch availableCNA
—github.com/openfga/openfga (Go)1.8.0 to before 1.8.131.8.13Patch availableGHSA-c72g-53hw-82q7
  • openfga Vendoropenfga Affected 1.8.0 to before 1.8.13 Fixed in 1.8.13 Patch available CNA
  • github.com/openfga/openfga (Go) Vendor— Affected 1.8.0 to before 1.8.13 Fixed in 1.8.13 Patch available GHSA-c72g-53hw-82q7

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:openfga:helm_charts:*:*:*:*:*:openfga:*:*0.2.16 to before 0.2.32Vulnerableopenfga
cpe:2.3:a:openfga:openfga:*:*:*:*:*:*:*:*1.8.0 to before 1.8.13Vulnerableopenfga
  • cpe:2.3:a:openfga:helm_charts:*:*:*:*:*:openfga:*:* Versions 0.2.16 to before 0.2.32 Vulnerable ·openfga
  • cpe:2.3:a:openfga:openfga:*:*:*:*:*:*:*:* Versions 1.8.0 to before 1.8.13 Vulnerable ·openfga

Remediation

  • Fix · CNA openfga (openfga) Fixed in 1.8.13
  • Fix · GHSA-c72g-53hw-82q7 github.com/openfga/openfga (Go) Fixed in 1.8.13 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-48371
  2. 2026-10-03 Alias added: GHSA-c72g-53hw-82q7

References

  • TI-2026-27194 Incorrect authorization in openfga CVSS 3.1HIGH 8.8
  • TI-2026-40204 OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset CVSS 3.1HIGH 8.1
  • TI-2026-20050 OpenFGA Improper Policy Enforcement CVSS 4.0MEDIUM 5.8
  • TI-2025-40089 OpenFGA Improper Policy Enforcement CVSS 4.0MEDIUM 5.8
  • TI-2025-34888 OpenFGA Authorization Bypass (Check) CVSS 4.0MEDIUM 5.8
  • TI-2025-29072 OpenFGA Authorization Bypass CVSS 4.0MEDIUM 5.8
See all 11 →

Sources