Read the docs
TI-2025-40089 Aliases CVE-2025-64751GHSA-2c64-vmv2-hgfc

OpenFGA Improper Policy Enforcement

Priority LOW 26CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-285.

Summary

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00313 24th percentileScored 2026-11-07
Fix Fixed openfga (openfga): 1.11.1github.com/openfga/openfga (Go): 1.11.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
openfgaopenfga1.4.0 to before 1.11.11.11.1Patch availableCNA
—github.com/openfga/openfga (Go)1.4.0 to before 1.11.11.11.1Patch availableGHSA-2c64-vmv2-hgfc
  • openfga Vendoropenfga Affected 1.4.0 to before 1.11.1 Fixed in 1.11.1 Patch available CNA
  • github.com/openfga/openfga (Go) Vendor— Affected 1.4.0 to before 1.11.1 Fixed in 1.11.1 Patch available GHSA-2c64-vmv2-hgfc

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:openfga:helm_charts:*:*:*:*:*:*:*:*0.1.34 to before 0.2.49Vulnerableopenfga
cpe:2.3:a:openfga:openfga:*:*:*:*:*:*:*:*1.4.0 to before 1.11.1Vulnerableopenfga
  • cpe:2.3:a:openfga:helm_charts:*:*:*:*:*:*:*:* Versions 0.1.34 to before 0.2.49 Vulnerable ·openfga
  • cpe:2.3:a:openfga:openfga:*:*:*:*:*:*:*:* Versions 1.4.0 to before 1.11.1 Vulnerable ·openfga

Remediation

  • Fix · CNA openfga (openfga) Fixed in 1.11.1
  • Fix · GHSA-2c64-vmv2-hgfc github.com/openfga/openfga (Go) Fixed in 1.11.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-64751
  2. 2026-10-03 Alias added: GHSA-2c64-vmv2-hgfc

References

  • TI-2026-27194 Incorrect authorization in openfga CVSS 3.1HIGH 8.8
  • TI-2026-40204 OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset CVSS 3.1HIGH 8.1
  • TI-2025-30697 OpenFGA Authorization Bypass CVSS 4.0MEDIUM 5.8
  • TI-2026-20050 OpenFGA Improper Policy Enforcement CVSS 4.0MEDIUM 5.8
  • TI-2025-34888 OpenFGA Authorization Bypass (Check) CVSS 4.0MEDIUM 5.8
  • TI-2025-29072 OpenFGA Authorization Bypass CVSS 4.0MEDIUM 5.8
See all 11 →

Sources