Read the docs
TI-2025-30771 Aliases CVE-2025-48492

GetSimple CMS RCE in Edit component

Priority HIGH 78CWE-77Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-77.

Summary

GetSimple CMS is a content management system. In versions starting from 3.3.16 to 3.3.21, an authenticated user with access to the Edit component can inject arbitrary PHP into a component file and execute it via a crafted query string, resulting in Remote Code Execution (RCE). This issue is set to be patched in version 3.3.22.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01002 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
GetSimpleCMS-CEGetSimpleCMS-CE3.3.16 – 3.3.21—No fix listedCNA
  • GetSimpleCMS-CE VendorGetSimpleCMS-CE Affected 3.3.16 – 3.3.21 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:getsimple-ce:getsimple_cms:*:*:*:*:community:*:*:*3.3.16 to before 3.3.22VulnerableGetSimpleCMS-CE
  • cpe:2.3:a:getsimple-ce:getsimple_cms:*:*:*:*:community:*:*:* Versions 3.3.16 to before 3.3.22 Vulnerable ·GetSimpleCMS-CE

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-48492

References

  • TI-2024-36775 GetSimple CMS CE 3.3.19 suffers from arbitrary code execution in the template editing… CVSS 3.1CRITICAL 9.8
  • TI-2024-36777 GetSimple CMS CE 3.3.19 is vulnerable to Server-Side Request Forgery (SSRF) in the backend plugin module. CVSS 3.1HIGH 8.8
  • TI-2026-21637 GetSimple CMS: Uploaded Files (feature) Arbitrary File Read Vulnerability CVSS 4.0HIGH 8.8
  • TI-2026-21606 Unauthenticated Information Disclosure via .htaccess Reliance in Sensitive Directories CVSS 4.0HIGH 8.7
  • TI-2024-36776 In the GetSimple CMS CE 3.3.19 management page, Server-Side Request Forgery (SSRF) can be… CVSS 3.1HIGH 7.2
  • TI-2026-21597 GetSimple CMS: Stored Cross-Site Scripting (XSS) via SVG File Upload (Authenticated) CVSS 4.0MEDIUM 6.9
See all 9 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences