Deno run with --allow-read and --deny-read flags results in allowed
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.41.3 and prior to versions 2.1.13, 2.2.13, and 2.3.2, `deno run --allow-read --deny-read main.ts` results in allowed, even though 'deny' should be stronger. The result is the same with all global unary permissions given as `--allow-* --deny-*`. This only affects a nonsensical combination of flags, so there shouldn't be a real impact on the userbase. Users may upgrade to version 2.1.13, 2.2.13, or 2.3.2 to receive a patch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| denoland | deno | 1.41.3 to before 2.1.13; 2.2.0 to before 2.2.13; 2.3.0 to before 2.3.2 | 2.1.13, 2.2.13, 2.3.2 | Patch available | CNA |
| — | deno (crates.io) | 1.41.3 to before 2.1.13 | 2.1.13 | Patch available | GHSA-xqxc-x6p3-w683 |
| — | deno (crates.io) | 2.2.0 to before 2.2.13 | 2.2.13 | Patch available | GHSA-xqxc-x6p3-w683 |
| — | deno (crates.io) | 2.3.0 to before 2.3.2 | 2.3.2 | Patch available | GHSA-xqxc-x6p3-w683 |
| — | deno_runtime (crates.io) | 0.150.0 to before 0.212.0 | 0.212.0 | Patch available | GHSA-xqxc-x6p3-w683 |
- deno Vendordenoland Affected 1.41.3 to before 2.1.13; 2.2.0 to before 2.2.13; 2.3.0 to before 2.3.2 Fixed in 2.1.13, 2.2.13, 2.3.2 Patch available CNA
- deno (crates.io) Vendor— Affected 1.41.3 to before 2.1.13 Fixed in 2.1.13 Patch available GHSA-xqxc-x6p3-w683
- deno (crates.io) Vendor— Affected 2.2.0 to before 2.2.13 Fixed in 2.2.13 Patch available GHSA-xqxc-x6p3-w683
- deno (crates.io) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-xqxc-x6p3-w683
- deno_runtime (crates.io) Vendor— Affected 0.150.0 to before 0.212.0 Fixed in 0.212.0 Patch available GHSA-xqxc-x6p3-w683
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:deno:deno:*:*:*:*:*:*:*:* | 1.41.3 to before 2.1.13; 2.2.0 to before 2.2.13; 2.3.0 to before 2.3.2 | Vulnerable | denoland |
- cpe:2.3:a:deno:deno:*:*:*:*:*:*:*:* Versions 1.41.3 to before 2.1.13; 2.2.0 to before 2.2.13; 2.3.0 to before 2.3.2 Vulnerable ·denoland
Remediation
- Fix · CNA deno (denoland) Fixed in 2.1.13, 2.2.13, 2.3.2
- Fix · GHSA-xqxc-x6p3-w683 deno (crates.io) Fixed in 2.1.13 Advisory →
- Fix · GHSA-xqxc-x6p3-w683 deno (crates.io) Fixed in 2.2.13 Advisory →
- Fix · GHSA-xqxc-x6p3-w683 deno (crates.io) Fixed in 2.3.2 Advisory →
- Fix · GHSA-xqxc-x6p3-w683 deno_runtime (crates.io) Fixed in 0.212.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-48888
- 2026-10-03 Alias added: GHSA-xqxc-x6p3-w683
References
Patch 5
- https://github.com/denoland/deno/pull/22894
- https://github.com/denoland/deno/pull/29213
- https://github.com/denoland/deno/commit/2f0fae9d9071dcaf0a689bc7097584b1b9ebc8db
- https://github.com/denoland/deno/commit/9d665572d3cd39f997e29e6daac7c1102fc5c04f
- https://github.com/denoland/deno/commit/ef315b56c26c9ef5f25284a5100d2ed525a148cf
More denoland Deno vulnerabilities
- TI-2026-21627 Deno has a Command Injection via Incomplete shell metacharacter blocklist in node:child_process CVSS 3.1CRITICAL 9.8
- TI-2025-17782 Deno's AES GCM authentication tags are not verified CVSS 4.0HIGH 7.7
- TI-2024-18537 *const c_void / ExternalPointer unsoundness leading to use-after-free CVSS 3.1HIGH 8.8
- TI-2024-18536 Deno arbitrary file descriptor close via `op_node_ipc_pipe()` leading to permission prompt bypass CVSS 3.1HIGH 8.8
- TI-2023-12990 Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization CVSS 3.1HIGH 8.8
- TI-2023-11328 Regular expression denial of service in deno CVSS 3.1HIGH 7.5
Sources
- CVE-2025-48888 · CVE Program
- CVE-2025-48888 · NVD
- FIRST EPSS
- GHSA-xqxc-x6p3-w683 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences