Read the docs
TI-2025-34660 Aliases CVE-2025-54940GHSA-ww7q-fq8q-pm4x

Code injection in wpengine Advanced Custom Fields

Priority LOW 21CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Active
Attack complexity
Low
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-94.

Summary

An HTML injection vulnerability exists in WordPress plugin "Advanced Custom Fields" prior to 6.4.3. If this vulnerability is exploited, crafted HTML code may be rendered and page display may be tampered.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00222 12th percentileScored 2026-11-07
Fix Fixed Advanced Custom Fields (WPEngine, Inc.): 6.4.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wpengineAdvanced Custom Fieldsbefore 6.4.36.4.3Patch availableCNA
  • Advanced Custom Fields Vendorwpengine Affected before 6.4.3 Fixed in 6.4.3 Patch available CNA

Remediation

  • Fix · CNA Advanced Custom Fields (WPEngine, Inc.) Fixed in 6.4.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-54940
  2. 2026-10-03 Alias added: GHSA-ww7q-fq8q-pm4x

References

  • TI-2023-06336 Better Search Replace <= 1.4.4 - Unauthenticated PHP Object Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-23053 Wordpress Advanced Custom Fields Pro plugin < 6.2.10 - Contributor+ Local File Inclusion vulnerability CVSS 3.1CRITICAL 9.9
  • TI-2019-07258 The WPGraphQL 0.2.3 plugin for WordPress allows remote attackers to register a new user… CVSS 3.0CRITICAL 9.8
  • TI-2019-07259 An issue was discovered in the WPGraphQL 0.2.3 plugin for WordPress. CVSS 3.0CRITICAL 9.1
  • TI-2024-03640 Genesis Blocks <= 3.1.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
  • TI-2022-01434 WPGraphQL WooCommerce <= 0.11.0 - Unauthenticated Coupon Codes Disclosure CVSS 3.1MEDIUM 5.3
See all 32 →

Sources