SQL Injection vulnerability in LimeSurvey before v.6.15.4+250710 allows a remote attacker…
Priority MEDIUM 40CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
SQL Injection vulnerability in LimeSurvey before v.6.15.4+250710 allows a remote attacker to obtain sensitive information from the database.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00532 45th percentileScored 2026-11-07
Fix Fixed limesurvey/limesurvey (Packagist): 6.15.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | limesurvey/limesurvey (Packagist) | before 6.15.4 | 6.15.4 | Patch available | GHSA-rccq-2fxq-7x3h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- limesurvey/limesurvey (Packagist) Vendor— Affected before 6.15.4 Fixed in 6.15.4 Patch available GHSA-rccq-2fxq-7x3h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:limesurvey:limesurvey:*:*:*:*:*:*:*:* | up to 6.15.3 | Vulnerable | LimeSurvey |
- cpe:2.3:a:limesurvey:limesurvey:*:*:*:*:*:*:*:* Versions up to 6.15.3 Vulnerable ·LimeSurvey
Remediation
- Fix · GHSA-rccq-2fxq-7x3h limesurvey/limesurvey (Packagist) Fixed in 6.15.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-56421
- 2026-10-03 Alias added: GHSA-rccq-2fxq-7x3h
- 2026-11-06 Priority changed: LOW → MEDIUM
References
Advisory 2
More Limesurvey vulnerabilities
- TI-2020-09194 LimeSurvey before 4.1.12+200324 contains a path traversal vulnerability in… CVSS 3.1CRITICAL 9.8
- TI-2024-28662 An issue in the js_localize.php function of LimeSurvey v6.6.2 and before allows attackers… CVSS 3.1HIGH 8.8
- TI-2024-26167 Lime Survey <= 6.5.12 is vulnerable to Cross Site Request Forgery (CSRF). CVSS 3.1HIGH 8.8
- TI-2022-21122 LimeSurvey before v5.0.4 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1HIGH 7.2
- TI-2007-03523 Multiple PHP remote file inclusion vulnerabilities in LimeSurvey (aka PHPSurveyor)… CVSS 2.0MEDIUM 6.8
- TI-2018-12189 An issue was discovered in TCPDF before 6.2.22. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2025-56421 · CVE Program
- CVE-2025-56421 · NVD
- FIRST EPSS
- GHSA-rccq-2fxq-7x3h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences