Apache Syncope: Remote Code Execution by delegated administrators
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations of a few Java interfaces; such implementations can be provided either as Java or Groovy classes, with the latter being particularly attractive as the machinery is set for runtime reload. Such a feature has been available for a while, but recently it was discovered that a malicious administrator can inject Groovy code that can be executed remotely by a running Apache Syncope Core instance. Users are recommended to upgrade to version 3.0.14 / 4.0.2, which fix this issue by forcing the Groovy code to run in a sandbox.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Syncope | 2.1 – 2.1.14; 3.0 – 3.0.13; 4.0 – 4.0.1 | — | No fix listed | CNA |
| — | org.apache.syncope.core:syncope-core-spring (Maven) | before 3.0.14 | 3.0.14 | Patch available | GHSA-825g-mm5v-ggq4 |
| — | org.apache.syncope.core:syncope-core-spring (Maven) | 4.0.0-M0 to before 4.0.2 | 4.0.2 | Patch available | GHSA-825g-mm5v-ggq4 |
- Apache Syncope VendorApache Affected 2.1 – 2.1.14; 3.0 – 3.0.13; 4.0 – 4.0.1 Fixed in — No fix listed CNA
- org.apache.syncope.core:syncope-core-spring (Maven) Vendor— Affected before 3.0.14 Fixed in 3.0.14 Patch available GHSA-825g-mm5v-ggq4
- org.apache.syncope.core:syncope-core-spring (Maven) Vendor— Affected 4.0.0-M0 to before 4.0.2 Fixed in 4.0.2 Patch available GHSA-825g-mm5v-ggq4
Remediation
- Fix · GHSA-825g-mm5v-ggq4 org.apache.syncope.core:syncope-core-spring (Maven) Fixed in 3.0.14 Advisory →
- Fix · GHSA-825g-mm5v-ggq4 org.apache.syncope.core:syncope-core-spring (Maven) Fixed in 4.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-57738
- 2026-10-03 Alias added: GHSA-825g-mm5v-ggq4
References
Advisory 2
Other 6
- https://github.com/apache/syncope/commit/88c2b5b0be9e2ed66007d672e786165bc266e717
- https://github.com/apache/syncope/commit/8b08c4d5785599a0e38830dcff89738b93f02a16
- https://issues.apache.org/jira/browse/SYNCOPE-1907
- https://syncope.apache.org/security#CVE-2025-57738
- http://github.com/apache/syncope
- http://www.openwall.com/lists/oss-security/2025/10/20/1
More Apache Syncope vulnerabilities
- TI-2026-38503 Apache Syncope: Remote Code Execution via Scripted Connector CVSS 3.1CRITICAL 9.8
- TI-2026-45025 Apache Syncope: RCE via Groovy Sandbox bypass CVSS 3.1CRITICAL 9.8
- TI-2026-44406 Apache Syncope: User self-service privilege escalation CVSS 3.1CRITICAL 9.8
- TI-2026-41245 Apache Syncope: SQL injection vulnerability in Audit Events search CVSS 3.1CRITICAL 9.8
- TI-2026-38491 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask CVSS 3.1CRITICAL 9.8
- TI-2020-01885 Injection in Apache Syncope CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-57738 · CVE Program
- CVE-2025-57738 · NVD
- FIRST EPSS
- GHSA-825g-mm5v-ggq4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences