Apache Syncope: User self-service privilege escalation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-269.
Summary
Improper Privilege Management vulnerability in Apache Syncope. When: * the all-Java user workflow adapter is configured, or * the Flowable user workflow adapter is configured, bearing a BPMN definition not requiring admin approval for user self registration of self update requests the following scenario could happen. A REST API call can allow the user to grant themselves one or more of defined Roles, thus gaining their Entitlements and becoming in fact an administrator; the actual Entitlements gained depend on the Roles that are effectively defined on the specific Syncope deployment. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-62183
- 2026-10-03 Alias added: GHSA-p386-8623-243g
References
More Apache Syncope vulnerabilities
- TI-2025-35632 Apache Syncope: Remote Code Execution by delegated administrators CVSS 3.1HIGH 7.2
- TI-2026-38503 Apache Syncope: Remote Code Execution via Scripted Connector CVSS 3.1CRITICAL 9.8
- TI-2026-45025 Apache Syncope: RCE via Groovy Sandbox bypass CVSS 3.1CRITICAL 9.8
- TI-2026-41245 Apache Syncope: SQL injection vulnerability in Audit Events search CVSS 3.1CRITICAL 9.8
- TI-2026-38491 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask CVSS 3.1CRITICAL 9.8
- TI-2020-01885 Injection in Apache Syncope CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-62183 · CVE Program
- CVE-2026-62183 · NVD
- FIRST EPSS
- GHSA-p386-8623-243g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences