DNN Vulnerable to Stored XSS Using Backend Admin Credentials
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 10.1.0, administrators and content editors can set html in module titles that could include javascript which could be used for XSS based attacks. This issue has been patched in version 10.1.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| DotNetNuke (DNN) | Dnn.Platform | before 10.1.0 | 10.1.0 | Patch available | CNA |
| — | DotNetNuke.Core (NuGet) | before 10.1.0 | 10.1.0 | Patch available | GHSA-gj8m-5492-q98h |
- Dnn.Platform VendorDotNetNuke (DNN) Affected before 10.1.0 Fixed in 10.1.0 Patch available CNA
- DotNetNuke.Core (NuGet) Vendor— Affected before 10.1.0 Fixed in 10.1.0 Patch available GHSA-gj8m-5492-q98h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dnnsoftware:dotnetnuke:*:*:*:*:*:*:*:* | before 10.1.0 | Vulnerable | DotNetNuke (DNN) |
- cpe:2.3:a:dnnsoftware:dotnetnuke:*:*:*:*:*:*:*:* Versions before 10.1.0 Vulnerable ·DotNetNuke (DNN)
Remediation
- Fix · CNA Dnn.Platform (dnnsoftware) Fixed in 10.1.0
- Fix · GHSA-gj8m-5492-q98h DotNetNuke.Core (NuGet) Fixed in 10.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-59546
- 2026-10-03 Alias added: GHSA-gj8m-5492-q98h
References
More DotNetNuke (DNN) Dotnetnuke vulnerabilities
- TI-2017-07201 Code injection in DotNetNuke CMS Fixed in 9.1.1 KEVCVSS 3.1HIGH 8.8
- TI-2018-12944 DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input… KEVCVSS 3.1HIGH 7.5
- TI-2018-11271 DNN (aka DotNetNuke) 9.2 through 9.2.1 uses a weak encryption algorithm to protect input parameters. KEVCVSS 3.1HIGH 7.5
- TI-2015-02468 The installation wizard in DotNetNuke (DNN) before 7.4.1 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2025-39546 DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite CVSS 3.1CRITICAL 10.0
- TI-2018-12945 DNN (aka DotNetNuke) 9.2 through 9.2.2 incorrectly converts encryption key source values… CVSS 3.1HIGH 7.5
Sources
- CVE-2025-59546 · CVE Program
- CVE-2025-59546 · NVD
- FIRST EPSS
- GHSA-gj8m-5492-q98h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences