HTTP 5XX Internal Server Errors
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
2N Access Commander application version 3.4.2 and prior returns HTTP 500 Internal Server Error responses when receiving malformed or manipulated requests, indicating improper handling of invalid input and potential security or availability impacts.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA 2N Access Commander (2N Telekomunikace a.s.) Fixed in 3.5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
2N Access Commander 3.5
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2025-37235 API - Insufficient Input ValidationPriority LOW 29
- TI-2025-37236 Cookies are not Invalidated upon Logout and Password ChangePriority LOW 27
Timeline
- 2026-10-02 Threatist record created from CVE-2025-59787
- 2026-10-03 Alias added: GHSA-mxhf-gjp2-rprv
References
More 2N Access Commander vulnerabilities
- TI-2025-37233 OS Command Injection over API CVSS 4.0HIGH 8.8
- TI-2025-37234 Log Pollution - Control Characters Not Escaped CVSS 4.0MEDIUM 6.9
- TI-2024-31590 In 2N Access Commander versions 3.1.1.2 and prior, a local attacker can escalate their… CVSS 3.1HIGH 7.8
- TI-2024-31588 Path traversal in 2N Access Commander CVSS 3.1HIGH 7.2
- TI-2024-31589 In 2N Access Commander versions 3.1.1.2 and prior, an Insufficient Verification of Data… CVSS 3.1HIGH 7.2
- TI-2025-37235 API - Insufficient Input Validation CVSS 4.0MEDIUM 5.3
Sources
- CVE-2025-59787 · CVE Program
- CVE-2025-59787 · NVD
- FIRST EPSS
- GHSA-mxhf-gjp2-rprv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences