Claude Code Vulnerable to Arbitrary Code Execution via Plugin Autoloading with Specific Yarn Versions
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution, Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-829 and CWE-862.
Summary
Claude Code is an agentic coding tool. Prior to Claude Code version 1.0.39, when using Claude Code with Yarn versions 2.0+, Yarn plugins are auto-executed when running yarn --version. This could lead to a bypass of the directory trust dialog in Claude Code, as plugins would be executed prior to the user accepting the risks of working in an untrusted directory. Users running Yarn Classic were unaffected by this issue. This issue has been fixed in version 1.0.39. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| anthropics | claude-code | before 1.0.39 | 1.0.39 | Patch available | CNA |
| — | @anthropic-ai/claude-code (npm) | before 1.0.39 | 1.0.39 | Patch available | GHSA-2jjv-qf24-vfm4 |
- claude-code Vendoranthropics Affected before 1.0.39 Fixed in 1.0.39 Patch available CNA
- @anthropic-ai/claude-code (npm) Vendor— Affected before 1.0.39 Fixed in 1.0.39 Patch available GHSA-2jjv-qf24-vfm4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:anthropic:claude_code:*:*:*:*:*:node.js:*:* | before 1.0.39 | Vulnerable | anthropics |
- cpe:2.3:a:anthropic:claude_code:*:*:*:*:*:node.js:*:* Versions before 1.0.39 Vulnerable ·anthropics
Remediation
- Fix · CNA claude-code (anthropics) Fixed in 1.0.39
- Fix · GHSA-2jjv-qf24-vfm4 @anthropic-ai/claude-code (npm) Fixed in 1.0.39 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-59828
- 2026-10-03 Alias added: GHSA-2jjv-qf24-vfm4
References
Advisory 2
More anthropics Claude Code vulnerabilities
- TI-2025-40558 Claude Code Command Validation Bypass Allows Arbitrary Code Execution CVSS 4.0HIGH 8.7
- TI-2025-36683 Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email CVSS 4.0HIGH 8.7
- TI-2025-37066 Claude Code's startup trust dialog could lead to Command Execution attack CVSS 4.0HIGH 8.7
- TI-2026-17554 Claude Code Leaks Data via Malicious Environment Configuration Before Trust Confirmation CVSS 4.0MEDIUM 5.3
- TI-2025-40093 @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes CVSS 4.0HIGH 8.7
- TI-2025-36422 Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution CVSS 4.0HIGH 8.7
Sources
- CVE-2025-59828 · CVE Program
- CVE-2025-59828 · NVD
- FIRST EPSS
- GHSA-2jjv-qf24-vfm4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences