LLaMA Factory's Chat API has Critical SSRF and LFI Vulnerabilities
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
LLaMA-Factory is a tuning library for large language models. Prior to version 0.9.4, a Server-Side Request Forgery (SSRF) vulnerability in the chat API allows any authenticated user to force the server to make arbitrary HTTP requests to internal and external networks. This can lead to the exposure of sensitive internal services, reconnaissance of the internal network, or interaction with third-party services. The same mechanism also allows for a Local File Inclusion (LFI) vulnerability, enabling users to read arbitrary files from the server's filesystem. The vulnerability exists in the `_process_request` function within `src/llamafactory/api/chat.py.` This function is responsible for processing incoming multimodal content, including images, videos, and audio provided via URLs. The function checks if the provided URL is a base64 data URI or a local file path (`os.path.isfile`). If neither is true, it falls back to treating the URL as a web URI and makes a direct HTTP GET request using `requests.get(url, stream=True).raw` without any validation or sanitization of the URL. Version 0.9.4 fixes the underlying issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| hiyouga | LLaMA-Factory | before 0.9.4 | 0.9.4 | Patch available | CNA |
| — | llamafactory (PyPI) | before 0.9.4 | 0.9.4 | Patch available | GHSA-527m-2xhr-j27g |
- LLaMA-Factory Vendorhiyouga Affected before 0.9.4 Fixed in 0.9.4 Patch available CNA
- llamafactory (PyPI) Vendor— Affected before 0.9.4 Fixed in 0.9.4 Patch available GHSA-527m-2xhr-j27g
Remediation
- Fix · CNA LLaMA-Factory (hiyouga) Fixed in 0.9.4
- Fix · GHSA-527m-2xhr-j27g llamafactory (PyPI) Fixed in 0.9.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-61784
- 2026-10-03 Alias added: GHSA-527m-2xhr-j27g
References
More hiyouga Llama-factory vulnerabilities
- TI-2026-41855 LLaMA-Factory 0.9.5 Remote Code Execution via WebUI Model Path CVSS 4.0CRITICAL 9.3
- TI-2024-35316 LLama Factory Remote OS Command Injection Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-33006 LLaMA-Factory Remote Code Execution (RCE) Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-29280 LLaMA-Factory Allows Arbitrary Code Execution via Unsafe Deserialization in Ilamafy_baichuan2.py CVSS 3.1HIGH 7.8
Sources
- CVE-2025-61784 · CVE Program
- CVE-2025-61784 · NVD
- FIRST EPSS
- GHSA-527m-2xhr-j27g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences