PrestaShop Checkout Backoffice directory traversal allows arbitrary file disclosure
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the backoffice is missing validation on input resulting in a directory traversal and arbitrary file disclosure. The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PrestaShop | ps_checkout | before 4.4.1; 5.0.0 to before 5.0.5 | 4.4.1, 5.0.5 | Patch available | CNA |
| — | prestashop/ps_checkout (Packagist) | before 4.4.1 | 4.4.1 | Patch available | GHSA-fpxp-pfqm-x54w |
| — | prestashop/ps_checkout (Packagist) | 5.0.0 to before 5.0.5 | 5.0.5 | Patch available | GHSA-fpxp-pfqm-x54w |
- ps_checkout VendorPrestaShop Affected before 4.4.1; 5.0.0 to before 5.0.5 Fixed in 4.4.1, 5.0.5 Patch available CNA
- prestashop/ps_checkout (Packagist) Vendor— Affected before 4.4.1 Fixed in 4.4.1 Patch available GHSA-fpxp-pfqm-x54w
- prestashop/ps_checkout (Packagist) Vendor— Affected 5.0.0 to before 5.0.5 Fixed in 5.0.5 Patch available GHSA-fpxp-pfqm-x54w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prestashop:prestashop_checkout:*:*:*:*:*:prestashop:*:* | before 7.4.4.1; 7.5.0.1 to before 7.5.0.5; 8.3.1.0 to before 8.4.4.1; 8.5.0.0 to before 8.5.0.5; 9.4.3.1 to before 9.5.0.5 | Vulnerable | PrestaShop |
- cpe:2.3:a:prestashop:prestashop_checkout:*:*:*:*:*:prestashop:*:* Versions before 7.4.4.1; 7.5.0.1 to before 7.5.0.5; 8.3.1.0 to before 8.4.4.1; 8.5.0.0 to before 8.5.0.5; 9.4.3.1 to before 9.5.0.5 Vulnerable ·PrestaShop
Remediation
- Fix · CNA ps_checkout (PrestaShopCorp) Fixed in 4.4.1, 5.0.5
- Fix · GHSA-fpxp-pfqm-x54w prestashop/ps_checkout (Packagist) Fixed in 4.4.1 Advisory →
- Fix · GHSA-fpxp-pfqm-x54w prestashop/ps_checkout (Packagist) Fixed in 5.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-61923
- 2026-10-03 Alias added: GHSA-fpxp-pfqm-x54w
References
More Prestashop Checkout vulnerabilities
- TI-2025-38271 PrestaShop Checkout allows customer account takeover via email CVSS 3.1CRITICAL 9.1
- TI-2025-38273 PrestaShop Checkout Target PayPal merchant account hijacking from backoffice CVSS 3.1LOW 3.8
Sources
- CVE-2025-61923 · CVE Program
- CVE-2025-61923 · NVD
- FIRST EPSS
- GHSA-fpxp-pfqm-x54w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences