PrestaShop Checkout Target PayPal merchant account hijacking from backoffice
Priority LOW 18CWE-184Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00269 19th percentileScored 2026-11-07
Fix Fixed ps_checkout (PrestaShopCorp): 4.4.1, 5.0.5prestashop/ps_checkout (Packagist): 4.4.1, 5.0.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PrestaShop | ps_checkout | before 4.4.1; 5.0.0 to before 5.0.5 | 4.4.1, 5.0.5 | Patch available | CNA |
| — | prestashop/ps_checkout (Packagist) | before 4.4.1 | 4.4.1 | Patch available | GHSA-wvpg-4wrh-5889 |
| — | prestashop/ps_checkout (Packagist) | 5.0.0 to before 5.0.5 | 5.0.5 | Patch available | GHSA-wvpg-4wrh-5889 |
- ps_checkout VendorPrestaShop Affected before 4.4.1; 5.0.0 to before 5.0.5 Fixed in 4.4.1, 5.0.5 Patch available CNA
- prestashop/ps_checkout (Packagist) Vendor— Affected before 4.4.1 Fixed in 4.4.1 Patch available GHSA-wvpg-4wrh-5889
- prestashop/ps_checkout (Packagist) Vendor— Affected 5.0.0 to before 5.0.5 Fixed in 5.0.5 Patch available GHSA-wvpg-4wrh-5889
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prestashop:prestashop_checkout:*:*:*:*:*:prestashop:*:* | before 7.4.4.1; 7.5.0.1 to before 7.5.0.5; 8.3.1.0 to before 8.4.4.1; 8.5.0.0 to before 8.5.0.5; 9.4.3.1 to before 9.5.0.5 | Vulnerable | PrestaShop |
- cpe:2.3:a:prestashop:prestashop_checkout:*:*:*:*:*:prestashop:*:* Versions before 7.4.4.1; 7.5.0.1 to before 7.5.0.5; 8.3.1.0 to before 8.4.4.1; 8.5.0.0 to before 8.5.0.5; 9.4.3.1 to before 9.5.0.5 Vulnerable ·PrestaShop
Remediation
- Fix · CNA ps_checkout (PrestaShopCorp) Fixed in 4.4.1, 5.0.5
- Fix · GHSA-wvpg-4wrh-5889 prestashop/ps_checkout (Packagist) Fixed in 4.4.1 Advisory →
- Fix · GHSA-wvpg-4wrh-5889 prestashop/ps_checkout (Packagist) Fixed in 5.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-61924
- 2026-10-03 Alias added: GHSA-wvpg-4wrh-5889
References
More Prestashop Checkout vulnerabilities
- TI-2025-38271 PrestaShop Checkout allows customer account takeover via email CVSS 3.1CRITICAL 9.1
- TI-2025-38272 PrestaShop Checkout Backoffice directory traversal allows arbitrary file disclosure CVSS 3.1MEDIUM 4.1
Sources
- CVE-2025-61924 · CVE Program
- CVE-2025-61924 · NVD
- FIRST EPSS
- GHSA-wvpg-4wrh-5889 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences