youki container escape via "masked path" abuse due to mount race conditions
Priority LOW 32CWE-363Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Youki is a container runtime written in Rust. In versions 0.5.6 and below, the initial validation of the source /dev/null is insufficient, allowing container escape when youki utilizes bind mounting the container's /dev/null as a file mask. This issue is fixed in version 0.5.7.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00259 17th percentileScored 2026-11-07
Fix Fixed youki (youki-dev): 0.5.7youki (crates.io): 0.5.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| youki-dev | youki | before 0.5.7 | 0.5.7 | Patch available | CNA |
| — | youki (crates.io) | before 0.5.7 | 0.5.7 | Patch available | GHSA-4g74-7cff-xcv8 |
- youki Vendoryouki-dev Affected before 0.5.7 Fixed in 0.5.7 Patch available CNA
- youki (crates.io) Vendor— Affected before 0.5.7 Fixed in 0.5.7 Patch available GHSA-4g74-7cff-xcv8
Remediation
- Fix · CNA youki (youki-dev) Fixed in 0.5.7
- Fix · GHSA-4g74-7cff-xcv8 youki (crates.io) Fixed in 0.5.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62161
- 2026-10-03 Alias added: GHSA-4g74-7cff-xcv8
References
Advisory 2
More youki-dev Youki vulnerabilities
- TI-2025-38811 youki container escape and denial of service due to arbitrary write gadgets and procfs write redirects CVSS 4.0HIGH 7.3
- TI-2025-34601 Youki Symlink Following Vulnerability CVSS 3.1HIGH 7.0
Sources
- CVE-2025-62161 · CVE Program
- CVE-2025-62161 · NVD
- FIRST EPSS
- GHSA-4g74-7cff-xcv8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences