youki container escape and denial of service due to arbitrary write gadgets and procfs write redirects
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Youki is a container runtime written in Rust. In versions 0.5.6 and below, youki’s apparmor handling performs insufficiently strict write-target validation, and when combined with path substitution during pathname resolution, can allow writes to unintended procfs locations. While resolving a path component-by-component, a shared-mount race can substitute intermediate components and redirect the final target. This issue is fixed in version 0.5.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| youki-dev | youki | before 0.5.7 | 0.5.7 | Patch available | CNA |
| — | youki (crates.io) | before 0.5.7 | 0.5.7 | Patch available | GHSA-vf95-55w6-qmrf |
- youki Vendoryouki-dev Affected before 0.5.7 Fixed in 0.5.7 Patch available CNA
- youki (crates.io) Vendor— Affected before 0.5.7 Fixed in 0.5.7 Patch available GHSA-vf95-55w6-qmrf
Remediation
- Fix · CNA youki (youki-dev) Fixed in 0.5.7
- Fix · GHSA-vf95-55w6-qmrf youki (crates.io) Fixed in 0.5.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62596
- 2026-10-03 Alias added: GHSA-vf95-55w6-qmrf
References
Advisory 2
More youki-dev Youki vulnerabilities
- TI-2025-38482 youki container escape via "masked path" abuse due to mount race conditions CVSS 4.0HIGH 7.3
- TI-2025-34601 Youki Symlink Following Vulnerability CVSS 3.1HIGH 7.0
Sources
- CVE-2025-62596 · CVE Program
- CVE-2025-62596 · NVD
- FIRST EPSS
- GHSA-vf95-55w6-qmrf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences