Pega Platform versions 7.1.0 through Infinity 25.1.0 are affected by a User Enumeration…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-204.
Summary
Pega Platform versions 7.1.0 through Infinity 25.1.0 are affected by a User Enumeration. This issue occurs during user authentication process, where a difference in response time could allow a remote unauthenticated user to determine if a username is valid or not. This only applies to deprecated basic-authentication feature and other more secure authentication mechanisms are recommended. A fix is being provided in the 24.1.4, 24.2.4, and 25.1.1 patch releases. Please note: Basic credentials authentication service type is deprecated started in 24.2 version: https://docs.pega.com/bundle/platform/page/platform/release-notes/security/whats-new-security-242.html.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pegasystems | Pega Infinity | 7.1.0 to before Infinity 25.1.1 | Infinity 25.1.1 | Patch available | CNA |
- Pega Infinity VendorPegasystems Affected 7.1.0 to before Infinity 25.1.1 Fixed in Infinity 25.1.1 Patch available CNA
Remediation
- Fix · CNA Pega Infinity (Pegasystems) Fixed in Infinity 25.1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62181
- 2026-10-03 Alias added: GHSA-h5xr-qq75-6hf9
References
More Pegasystems vulnerabilities
- TI-2021-09101 Improper authentication in Pegasystems Pega Infinity CVSS 3.1CRITICAL 9.8
- TI-2022-08033 Deserialization of untrusted data in Pegasystems Pega Infinity CVSS 3.1CRITICAL 9.8
- TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
- TI-2019-12313 Pega Platform 8.2.1 allows LDAP injection because a username can contain a * character… CVSS 3.1CRITICAL 9.8
- TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
- TI-2026-11602 Pega Platform versions 7.1.0 through 25.1.2 are affected by an improper validation of… CVSS 4.0HIGH 8.8
Sources
- CVE-2025-62181 · CVE Program
- CVE-2025-62181 · NVD
- FIRST EPSS
- GHSA-h5xr-qq75-6hf9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences