Envoy Lua filter use-after-free when oversized rewritten response body causes crash
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Will not fix Red Hat: no fix planned
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.
Summary
Envoy is an open source edge and service proxy. Envoy versions earlier than 1.36.2, 1.35.6, 1.34.10, and 1.33.12 contain a use-after-free vulnerability in the Lua filter. When a Lua script executing in the response phase rewrites a response body so that its size exceeds the configured per_connection_buffer_limit_bytes (default 1MB), Envoy generates a local reply whose headers override the original response headers, leaving dangling references and causing a crash. This results in denial of service. Updating to versions 1.36.2, 1.35.6, 1.34.10, or 1.33.12 fixes the issue. Increasing per_connection_buffer_limit_bytes (and for HTTP/2 the initial_stream_window_size) or increasing per_request_buffer_limit_bytes / request_body_buffer_limit can reduce the likelihood of triggering the condition but does not correct the underlying memory safety flaw.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| envoyproxy | envoy | 1.36.0 – 1.36.1; 1.350 – 1.35.5; 1.34.0 – 1.34.9; up to 1.33.11 | — | No fix listed | CNA |
- envoy Vendorenvoyproxy Affected 1.36.0 – 1.36.1; 1.350 – 1.35.5; 1.34.0 – 1.34.9; up to 1.33.11 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* | before 1.33.12; 1.34.0 to before 1.34.10; 1.35.0 to before 1.35.6; 1.36.0 to before 1.36.2 | Vulnerable | envoyproxy |
- cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* Versions before 1.33.12; 1.34.0 to before 1.34.10; 1.35.0 to before 1.35.6; 1.36.0 to before 1.36.2 Vulnerable ·envoyproxy
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 2 | Affected | No fix planned: Out of support scope |
| OpenShift Service Mesh 3 | Affected | No fix planned: Out of support scope |
Not affected: 1 product
- OpenShift Service Mesh 3
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62504
References
More envoyproxy Envoy vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-20001 HTTP/2: CPU exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2024-18524 HTTP/2: memory exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2023-12215 Envoy client may fake the header `x-envoy-original-path` CVSS 3.1CRITICAL 9.1
- TI-2023-18002 Envoy vulnerable to OAuth2 credentials exploit with permanent validity CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-62504 · CVE Program
- CVE-2025-62504 · NVD
- FIRST EPSS
- CVE-2025-62504 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences