Read the docs
TI-2025-38759 Aliases CVE-2025-62519GHSA-fxm2-cmwj-qvx4

phpMyFAQ has Authenticated SQL Injection in Configuration Update Functionality

Priority HIGH 67CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

phpMyFAQ is an open source FAQ web application. Prior to version 4.0.14, an authenticated SQL injection vulnerability in the main configuration update functionality of phpMyFAQ allows a privileged user with 'Configuration Edit' permissions to execute arbitrary SQL commands. Successful exploitation can lead to a full compromise of the database, including reading, modifying, or deleting all data, as well as potential remote code execution depending on the database configuration. This issue has been patched in version 4.0.14.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00798 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpMyFAQ (thorsten): 4.0.14thorsten/phpmyfaq (Packagist): 4.0.14+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
thorstenphpMyFAQbefore 4.0.144.0.14Patch availableCNA
—thorsten/phpmyfaq (Packagist)before 4.0.144.0.14Patch availableGHSA-fxm2-cmwj-qvx4
—phpmyfaq/phpmyfaq (Packagist)before 4.0.144.0.14Patch availableGHSA-fxm2-cmwj-qvx4
  • phpMyFAQ Vendorthorsten Affected before 4.0.14 Fixed in 4.0.14 Patch available CNA
  • thorsten/phpmyfaq (Packagist) Vendor— Affected before 4.0.14 Fixed in 4.0.14 Patch available GHSA-fxm2-cmwj-qvx4
  • phpmyfaq/phpmyfaq (Packagist) Vendor— Affected before 4.0.14 Fixed in 4.0.14 Patch available GHSA-fxm2-cmwj-qvx4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:*before 4.0.14Vulnerablethorsten
  • cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:* Versions before 4.0.14 Vulnerable ·thorsten

Remediation

  • Fix · CNA phpMyFAQ (thorsten) Fixed in 4.0.14
  • Fix · GHSA-fxm2-cmwj-qvx4 thorsten/phpmyfaq (Packagist) Fixed in 4.0.14 Advisory →
  • Fix · GHSA-fxm2-cmwj-qvx4 phpmyfaq/phpmyfaq (Packagist) Fixed in 4.0.14 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-62519
  2. 2026-10-03 Alias added: GHSA-fxm2-cmwj-qvx4

References

  • TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
  • TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
  • TI-2025-37331 phpMyFAQ duplicate email registration allows multiple accounts with the same email CVSS 3.1CRITICAL 9.8
  • TI-2024-36257 phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available CVSS 3.1HIGH 8.6
  • TI-2023-03720 Improper Neutralization of Formula Elements in a CSV File in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
  • TI-2023-00749 Command Injection in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
See all 153 →

Sources