Read the docs
TI-2025-39054 Aliases CVE-2025-62905GHSA-2x26-r374-v69m

WordPress Query Posts plugin <= 0.3.2 - Cross Site Scripting (XSS) vulnerability

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Justin Tadlock Query Posts query-posts allows Stored XSS.This issue affects Query Posts: from n/a through <= 0.3.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0021 11th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Justin TadlockQuery Postsup to 0.3.2—No fix listedCNA
  • Query Posts VendorJustin Tadlock Affected up to 0.3.2 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-62905
  2. 2026-10-03 Alias added: GHSA-2x26-r374-v69m

References

  • TI-2024-07502 JavaScript Logic <= 0.1 - CSRF to Stored XSS CVSS 3.1MEDIUM 6.1
  • TI-2024-07494 Widgets Reset <= 0.1 - Settings Update via CSRF CVSS 3.1MEDIUM 4.3
  • TI-2024-22422 WordPress Unique theme <= 0.3.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2025-38948 WordPress Series plugin <= 2.0.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5

Sources