Read the docs
TI-2024-22422 Aliases CVE-2024-33952GHSA-h2gr-w6qq-3rf4

WordPress Unique theme <= 0.3.0 - Cross Site Scripting (XSS) vulnerability

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Justin Tadlock Unique allows Stored XSS.This issue affects Unique: from n/a through 0.3.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00408 35th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Justin TadlockUniqueup to 0.3.0—No fix listedCNA
  • Unique VendorJustin Tadlock Affected up to 0.3.0 Fixed in — No fix listed CNA

CPE names CISA-ADP · 1

CPEVersionsRoleVendor
cpe:2.3:a:wordpress:unique_theme:-:*:*:*:*:*:*:*not specified by CISA-ADP—WordPress
  • cpe:2.3:a:wordpress:unique_theme:-:*:*:*:*:*:*:* Versions not specified by CISA-ADP — ·WordPress

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-33952
  2. 2026-10-03 Alias added: GHSA-h2gr-w6qq-3rf4

References

  • TI-2024-07502 JavaScript Logic <= 0.1 - CSRF to Stored XSS CVSS 3.1MEDIUM 6.1
  • TI-2024-07494 Widgets Reset <= 0.1 - Settings Update via CSRF CVSS 3.1MEDIUM 4.3
  • TI-2025-39054 WordPress Query Posts plugin <= 0.3.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2025-38948 WordPress Series plugin <= 2.0.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5

Sources