Read the docs
TI-2025-39843 Aliases CVE-2025-64430GHSA-x4qj-2f4q-r4rx

Parse Server Vulnerable to Server-Side Request Forgery (SSRF) in File Upload via URI Format

Priority MEDIUM 40CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions 4.2.0 through 7.5.3, and 8.0.0 through 8.3.1-alpha.1, there is a Server-Side Request Forgery (SSRF) vulnerability in the file upload functionality when trying to upload a Parse.File with uri parameter, allowing execution of an arbitrary URI. The vulnerability stems from a file upload feature in which Parse Server retrieves the file data from a URI that is provided in the request. A request to the provided URI is executed, but the response is not stored in Parse Server's file storage as the server crashes upon receiving the response. This issue is fixed in versions 7.5.4 and 8.4.0-alpha.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00645 51st percentileScored 2026-11-07
Fix Fixed parse-server (parse-community): 7.5.4parse-server (npm): 7.5.4, 8.4.0-alpha.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
parse-communityparse-server4.2.0 to before 7.5.4; 8.0.0 – 8.4.0-alpha.17.5.4Patch availableCNA
—parse-server (npm)4.2.0 to before 7.5.47.5.4Patch availableGHSA-x4qj-2f4q-r4rx
—parse-server (npm)8.0.0 to before 8.4.0-alpha.28.4.0-alpha.2Patch availableGHSA-x4qj-2f4q-r4rx
  • parse-server Vendorparse-community Affected 4.2.0 to before 7.5.4; 8.0.0 – 8.4.0-alpha.1 Fixed in 7.5.4 Patch available CNA
  • parse-server (npm) Vendor— Affected 4.2.0 to before 7.5.4 Fixed in 7.5.4 Patch available GHSA-x4qj-2f4q-r4rx
  • parse-server (npm) Vendor— Affected 8.0.0 to before 8.4.0-alpha.2 Fixed in 8.4.0-alpha.2 Patch available GHSA-x4qj-2f4q-r4rx

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:*——parse-community
  • cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:* Versions — — ·parse-community

Remediation

  • Fix · CNA parse-server (parse-community) Fixed in 7.5.4
  • Fix · GHSA-x4qj-2f4q-r4rx parse-server (npm) Fixed in 7.5.4 Advisory →
  • Fix · GHSA-x4qj-2f4q-r4rx parse-server (npm) Fixed in 8.4.0-alpha.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-64430
  2. 2026-10-03 Alias added: GHSA-x4qj-2f4q-r4rx
  3. 2026-10-20 EPSS moved to the 50th–90th percentile

References

  • TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
  • TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
  • TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
  • TI-2025-35510 parse is a package designed to parse JavaScript SDK. CVSS 3.1MEDIUM 6.5
  • TI-2024-26265 ZDI-CAN-23894: Parse Server literalizeRegexPart SQL Injection Authentication Bypass Vulnerability CVSS 3.1CRITICAL 9.8
See all 158 →

Sources